Bug 101 - Browsing problem for added printers
Browsing problem for added printers
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.0preX
Other other
: P2 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-05-20 17:21 UTC by Tim Potter
Modified: 2005-08-24 10:17 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Potter 2003-05-20 17:21:47 UTC
From the samba-technical mailing list.  I thought this problem was fixed ages ago:

http://samba.cadcamlab.org/lists/samba-technical/May2002/00360.html

From: Jianliang Lu <j.lu@tiesse.com>
To: samba-technical@lists.samba.org
X-OriginatingIP: 151.24.153.138 (lu)
Subject: Browsing problem for printers on Samba3.0 a24.
Reply-To: j.lu@tiesse.com
                                                                               
                                   
When a user would add a printer, that was shared on Samba, on his NT machine,
he cannot find the printers from the shared list. The problem is that the
browsing flag of Samba does not include the SV_TYPE_PRINTQ_SERVER
(0x00000200), so a rap API_NetServerEnum2 (104) was failed to get printer
servers.
I think that we should put the "default_server_announce |=
SV_TYPE_PRINTQ_SERVER;" on the routine "set_default_server_announce_type",
because the "update_server_announce_as_printserver" was called only by the
smbd, not nmbd, that was responsible for the browsing announcement.
                                                                               
                                   
Jianliang Lu
TieSse s.p.a.
Via Jervis, 60.  10015 Ivrea (To) - Italy
j.lu@tiesse.com
luj@libero.it
Comment 1 Gerald (Jerry) Carter 2003-05-21 10:49:19 UTC
passing off
Comment 2 Gerald (Jerry) Carter 2003-11-19 13:31:25 UTC
taking this over
Comment 3 Gerald (Jerry) Carter 2003-12-12 08:27:49 UTC
reseting target milestone.  3.0.1 has been frozen.  WIll have to 
re-evaluate these.
Comment 4 Gerald (Jerry) Carter 2004-01-31 10:30:06 UTC
patch from Jianliang Lu applied for 3.0.2rc2
Comment 5 Gerald (Jerry) Carter 2005-02-07 07:57:28 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:17:11 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.