Bug 10095 - Samba does not properly indicate DFS reparse points in the responses to FIND FIRST/FIND NEXT
Samba does not properly indicate DFS reparse points in the responses to FIND ...
Status: RESOLVED DUPLICATE of bug 10097
Product: Samba 3.6
Classification: Unclassified
Component: File services
unspecified
All All
: P5 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 14:53 UTC by Richard Sharpe
Modified: 2013-08-19 21:35 UTC (History)
2 users (show)

See Also:


Attachments
the patch (3.12 KB, patch)
2013-08-18 14:53 UTC, Richard Sharpe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Sharpe 2013-08-18 14:53:25 UTC
Created attachment 9144 [details]
the patch

When there is a reparse point on a file or folder, windows returns the REPARSE TAG in the EA length field of three INFO LEVELS:

    SMB_FIND_FILE_BOTH_DIRECTORY_INFO,
    SMB_FIND_ID_FULL_DIRECTORY_INFO,
    SMB_FIND_ID_BOTH_DIRECTORY_INFO

This, I believe, is the fundamental reason that you can have either EAs or reparse points on files/folders.

In any event, since we support DFS links but not reparse points, we should return the IO_REPARSE_TAG_DFS tag in the ea length field if the folder in question is a DFS link.

This allows MAC OS X to follow DFS links handed out by Samba and might allow XP to do so as well.

Attached is a possible patch for this.

This problem exists in 3.5, 3.6, 4.0, 4.1 and master.
Comment 1 Björn Jacke 2013-08-19 14:33:55 UTC
CC: bj@sernet.de
Comment 2 Jeremy Allison 2013-08-19 21:35:43 UTC

*** This bug has been marked as a duplicate of bug 10097 ***