Bug 10091 - ESRI ArcGIS is unable to write specific files on a samba share when using SMB 2
ESRI ArcGIS is unable to write specific files on a samba share when using SMB 2
Status: RESOLVED DUPLICATE of bug 10140
Product: Samba 3.6
Classification: Unclassified
Component: SMB2
3.6.16
x64 Windows 7
: P5 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 14:35 UTC by Klaus Braun
Modified: 2013-09-14 09:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Braun 2013-08-16 14:35:22 UTC
On my Windows 7 computer I am using the ESRI Software ArcGIS 10.1 which is the world leading Geographical Information System (GIS). Under specific circumstances this software is unable to write files to a samba share when samba uses SMB 2. When samba uses SMB 1 (the default) the problem doesn't occur.

On the internet I found a discussion concerning the issue, that specific Microsoft updates may result in data corruption with file geodatabases or shapefiles created on a network share on a Windows file server:

http://support.esri.com/fr/knowledgebase/techarticles/detail/41119

It is said that the problem comes from the RDBSS.SYS component on the Windows 7 computer.

Three days ago Microsoft published a hotfix to solve the problem:

http://blogs.msdn.com/b/winsdk/archive/2013/05/13/roll-up-update-kb-2775511-reports-with-smb-2-0-data-truncation.aspx

I installed this hotfix, but without success: I still get the same error when I
try to create files in a file geodatabases on a samba share when samba uses SMB 2. 

I'm not really sure what is causing the problem: Samba, ArcGIS or Microsoft.

Maybe the issue is correlated to the issue mentioned above and samba is affected by this or not or maybe there is another bug in samba or not.

In any case for me it would be helpful to know if samba could be the problem or if I should concentrate on ArcGIS or Microsoft to find a solution.


Thanks 

Klaus
Comment 1 Klaus Braun 2013-09-14 09:15:19 UTC

*** This bug has been marked as a duplicate of bug 10140 ***