Bug 10067 - If User's password got '@' in it, then we couldn't mount the share directory.
If User's password got '@' in it, then we couldn't mount the share directory.
Status: RESOLVED INVALID
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient
unspecified
All Mac OS X
: P2 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 09:24 UTC by BillZhao
Modified: 2013-08-06 06:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BillZhao 2013-08-03 09:24:52 UTC
We have a share Directory on Windows 2003 which is C:\\share
We have a user who's account is bill , password is "pwd@123"

we use below command to mount directory to our Mac.
/usr/bin/osascript -e 'mount volume "bill:pwd@123@myserver/PUBLIC" '

When we run this command, a warning message windows showed up and
it said we couldn't find domain 123, and mount failed.

looks like samba make a mistake about the password.
Comment 1 Christian Ambach 2013-08-03 10:25:08 UTC
I do not believe this is a Samba problem, more a problem with your Mac client (or how the command you use expects username and password to be delimited)

Maybe you need to escape the at sign? Something like
/usr/bin/osascript -e 'mount volume "bill:pwd\@123@myserver/PUBLIC" '
Comment 2 BillZhao 2013-08-06 06:02:30 UTC
Thanks, you're totally right, I figure out what should I do in this case. The answer is
/usr/bin/osascript -e 'mount volume "smb://myserver/PUBLIC as user name "bill" with password "zhaorui@123" "'. 
This command could work.
It's not a bug of samba.


(In reply to comment #1)
> I do not believe this is a Samba problem, more a problem with your Mac client
> (or how the command you use expects username and password to be delimited)
> 
> Maybe you need to escape the at sign? Something like
> /usr/bin/osascript -e 'mount volume "bill:pwd\@123@myserver/PUBLIC" '