Bug 1006 - Can't See Windows XP Pro Shares Browsing Network
Can't See Windows XP Pro Shares Browsing Network
Status: RESOLVED DUPLICATE of bug 1004
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Depends on:
  Show dependency treegraph
Reported: 2004-01-26 08:27 UTC by James Shanks
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description James Shanks 2004-01-26 08:27:19 UTC
I though that this was meerly a configuration error, but after working with 
all versions of Samba 3.x including the betas and speaking with other users, I 
have come to the conclusion that this is a bug.

In any configuration that I have tried (Domain Controller, Stand Alone, LDAP, 
tdbsam, etc.) if the Samba server is the master browser on the network, shares 
on Windows XP Professional SP1 systems will not show up in the "Network 
Neighborhood".  Windows 2000 and Linux shares work fine and in fact Windows XP 
systems can see the shares on Linux and Windows 2000 machines.  The only way 
that I can make it work is to make a Windows 2000 or Windows XP machine the 
master browser.  I did not have this problem on Samba 2.2.x and I am forced to 
continue using 2.2.8a as a domain controller until I can get this to work.
Comment 1 James Shanks 2004-02-25 09:21:52 UTC
Problem persists with 3.02 and 3.02a.
Comment 2 James Shanks 2004-02-26 06:48:11 UTC
I've found that this is the same problem as bug 1004.  After doing an 
inventory of all 50 of our Windows XP Professional workstations, I've found 
that due to a naming convention in our organization, the Server Comment on all 
workstations contained a "'" which causes a string overflow problem in samba 
and samba does not advertise shares on the workstation.
Comment 3 Gerald (Jerry) Carter 2004-03-04 10:19:48 UTC
Thanks for the feedback.  I'm closing this as a duplicate.

*** This bug has been marked as a duplicate of 1004 ***
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:27:49 UTC
database cleanup