Bug 10032 - DNS zone changes are not recognized
DNS zone changes are not recognized
Status: RESOLVED DUPLICATE of bug 9404
Product: Samba 4.0
Classification: Unclassified
Component: DNS server
4.0.7
All All
: P5 normal
: ---
Assigned To: Kai Blin
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 20:07 UTC by kristofer
Modified: 2013-07-17 20:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kristofer 2013-07-17 20:07:07 UTC
1. Set up a server using "dns forwarder" to forward unknown requests.
2. Preform a lookup on a domain that requires Samba to forward the request (test.domain.com).
3. Create a DNS zone in Samba called domain.com, with new records.
4. Samba still forwards the request to the forwarder - it doesn't look at the new zone in Active Directory.
5. Restarting Samba will clear and resolve the issue.

The same result when removing a zone:

1. Set up a server using "dns forwarder" to forward unknown requests.
5. Ensure the domain will be resolvable by the forwarder.
2. Create a DNS zone in Samba called domain.com, with new records.
3. Preform a lookup on a record in the zone (test.domain.com).
4. Delete the zone from Active Directory.
5. Even though the zone is available at the forwarder, Samba will return no records.
6. Restarting Samba will clear and resolve the issue.

Most recently tested on Samba 4.0.7 and 4.0.7-SerNet-RedHat-4.el6
Comment 1 Björn Jacke 2013-07-17 20:37:37 UTC

*** This bug has been marked as a duplicate of bug 9404 ***