Bug 10023 - Unable to add drivers for networked printers
Summary: Unable to add drivers for networked printers
Alias: None
Product: Samba 3.6
Classification: Unclassified
Component: Printing (show other bugs)
Version: 3.6.9
Hardware: x64 Linux
: P5 normal
Target Milestone: ---
Assignee: printing-maintainers
QA Contact: Samba QA Contact
Depends on:
Reported: 2013-07-16 01:57 UTC by Teddles
Modified: 2021-01-04 21:05 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Teddles 2013-07-16 01:57:39 UTC
After following this guide: https://wiki.samba.org/index.php/Samba_as_a_print_server#Uploading_printer_drivers_for_Point.27n.27Print_driver_installation

I have been having issues adding a driver to the Samba server. When I get to the point with the Add Printer Driver Wizard on server window appears, and I select my driver, I am then prompted with "Cannot copy file to destination directory". 

I have verified that the user / group does indeed have SePrintOperatorPrivilege and a user in #samba on freenode has also verified this.

I have double checked file permissions, when the combinations that I used failed, I resorted to chmod'ing 777 to the path file for the [print$] share and trying again. 

I have tried adding the files manually to the path folder of the [print$] share and then trying to connect to the printers, this failed (it couldn't find a suitable driver. 

I tried cupsaddsmb -v "printermodel", which failed saying that it couldn't find any suitable/compatible Windows Drivers. 

Tried the following:
HP: C309g-m driver, PCL5 for Windows 7 x86 and x64, PCL6 for Windows 7 x86 and x64, and PS driver for Windows 7 x86 and x64. 

All of these do not work.

I am not sure if this cause is due to folder/file permissions, samba permissions (the shares are writeable = yes), or driver problems at this point. 

I asked if I should file a bug report about this, and was told yes.
Comment 1 Björn Jacke 2021-01-04 21:05:42 UTC
you describe more than one problem here and the main issue is most probably a configuration issue ("Cannot copy file to destination directory"). Bugzilla is not the right place to get that solved, the mailing list or one of the commercial support offerings from https://www.samba.org/samba/support/ wouuld have been the right advice for you.