Bug 10018 - ctdb ip does not return expect results, test on 2.3
ctdb ip does not return expect results, test on 2.3
Status: RESOLVED INVALID
Product: CTDB 2.5.x or older
Classification: Unclassified
Component: ctdb
unspecified
x64 Linux
: P5 normal
: ---
Assigned To: Amitay Isaacs
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 17:03 UTC by Jeffrey Lang
Modified: 2016-09-12 09:00 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Lang 2013-07-14 17:03:25 UTC
When running the "ctdb ip" command, should get a list and state of the public ip address.  I get only the following:

[root@mmmssn1 ctdb-2.3]# ctdb ip
Public IPs on node 0
Comment 1 Amitay Isaacs 2013-10-03 01:41:08 UTC
The behaviour of "ctdb ip" command was changed in 2010. "ctdb ip" by default only displays the IP addresses known by current node.  More information is available with "ctdb ip -v" command.

Does "ctdb ip -v" command give you the required output?

If the current node does not know about any public IPs, then "ctdb ip" command will not display any information.
Comment 2 Martin Schwenke 2016-09-12 09:00:48 UTC
No further information received, assuming not a bug.

In 4.5.x can get list of IPs from all nodes with "ctdb ip all".  On prior versions, may need to use "ctdb ip -n all".