Bug 1000 - DUP of #999 :smbmount unable to use uid and gid options with kernel 2.6
DUP of #999 :smbmount unable to use uid and gid options with kernel 2.6
Status: RESOLVED DUPLICATE of bug 999
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.1
Other other
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 09:16 UTC by Christophe Borivant (550 5.1.1 Recipient address rejected: User unknown in local recipient table)
Modified: 2009-07-28 11:09 UTC (History)
0 users

See Also:


Attachments
error istalling Samba 3.2.11 fc10 (1.57 KB, text/plain)
2009-07-28 11:09 UTC, Carlos Jarero
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Borivant (550 5.1.1 Recipient address rejected: User unknown in local recipient table) 2004-01-23 09:16:12 UTC
OS Gentoo Linux glibc 2.3.2 gcc 3.2.3 
When i try to mount a share with uig and gid option, the uid and gid  mapping 
doesn't work. I get the original uids and gids from the server. 
This prevent me to write in the share. 
 
When I do the same thing but running a 2.4 kernel instead of a 2.6, everything 
is perfect. 
I first thought it was because the glibc and gcc had been compiled against 2.4 
kernel headers. But I updated my kernel headers, recompiled glibc, gcc and 
samba, and the problem still occurs. 
 
Hope i'm in the right place because it's my first bug report ......
Comment 1 Gerald (Jerry) Carter 2004-01-26 10:33:16 UTC

*** This bug has been marked as a duplicate of 999 ***
Comment 2 Christophe Borivant (550 5.1.1 Recipient address rejected: User unknown in local recipient table) 2004-01-27 07:41:51 UTC
I've been able to reproduce the problem on a very simple configuration. 
Both server and client sides are on my laptop and I use version 3.0.1. 
Here is the server configuration : 
# Global parameters 
[global] 
        workgroup = DSI 
        server string = Samba Server %v 
        passwd program = /usr/bin/passwd %u 
        passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n 
        unix password sync = Yes 
        log file = /var/log/samba/log.%m 
        max log size = 50 
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 
        dns proxy = No 
 
[homes] 
        comment = Home Directories 
        read only = No 
 
On the client side, I try to do this connected as root: 
smbmount //localhost/borivant /mnt/test -o 
username=borivant,uid=oracle,gid=dba 
 
Once mounted an ls -l /mnt/test should show each files and directories 
belonging to oracle from the dba group. 
 
That's ok when running a 2.4 kernel but not when running a 2.6 kernel. 
I tried to mount shares the same way against a 2.2.8 samba server and I have 
no problem. 
So the problem seems to be only against a samba 3.0.x server. 
Comment 3 Carlos Jarero 2009-07-28 11:09:05 UTC
Created attachment 4477 [details]
error istalling Samba 3.2.11 fc10

please help, I'am newusuer in linux fedora can you helpme to resolve this problem.
thanks