Bug 9839 - winbind nss info and template homedir not honored in AD DC setup
winbind nss info and template homedir not honored in AD DC setup
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Winbind
4.0.5
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on: 9898
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-30 08:06 UTC by Björn Jacke
Modified: 2015-07-31 08:26 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2013-04-30 08:06:37 UTC
with winbind being enabled in nsswitch.conf on an AD DC it is not possible to tell winbind which home directory the users should have. The default is /home/DOMAIN/username.

Setting "winbind nss info = rfc2307" should be supported so that the home directory will be the one configured in AD.

Also something like "template homedir = /home/%u" is not usable. with that setting all users will have the home directory "/home/%u" bevause %u is not being expanded.
Comment 1 Björn Jacke 2013-06-27 08:19:09 UTC
Andrew, this probably depends on bug 9898, the fact that smb.conf variables are not evaluated generally in samba 4, right?
Comment 2 Andrew Bartlett 2013-06-27 08:34:32 UTC
The issue is more that we need to replace the winbind implementation.  The s4 winbindd just doens't have the code to implement winbind nss info, for example - it is purely RPC based, with an occasional sprinkle of LDAP.

the template homedir stuff does work, but it uses %DOMAIN% not %d (a poor choice in retrospect). 

Now we have just one build system, combining the two winbind implementations seems a little more practical, but still a large task.
Comment 3 Stefan Metzmacher 2015-07-31 08:26:59 UTC
We use the source3 winbind since 4.2