Bug 976 - File names are converted to raw unicode if they contain characters not in "unix charset"
File names are converted to raw unicode if they contain characters not in "un...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.1
All Linux
: P4 minor
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 02:52 UTC by Sergey Svishchev
Modified: 2005-08-24 10:21 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Svishchev 2004-01-16 02:52:51 UTC
System: Red Hat 9, kernel 2.4.20-24.9 (custom build with POSIX ACL support),
glibc 2.3.2-11.9.

Samba 3.0.1 (built from official source RPM, --with-acl-support added)

smb.conf:

[global]
        dos charset = IBM866
        unix charset = KOI8-R

Windows 2000 or XP client:

Locale: Russian
Language settings: Cyrillic (default), Western Europe and United States
Input languages: English (United states) (default), Russian

Create a file named "foo №1".  The funny character is NUMERO SIGN, 0x2116 in
Unicode, 0xfc in IBM866 encoding, and not encoded at all in KOI8-R.

File gets created successfully, but its name changes to "foo\ ^V\!1" (as seen by
zsh.exe from Cygwin) -- that's raw unicode embedded into ASCII string!
Comment 1 Jelmer Vernooij 2004-06-10 09:01:30 UTC
Where do you create the file? On Unix or on Windows? 
Comment 2 Sergey Svishchev 2004-06-10 11:16:35 UTC
On Windows.
Comment 3 Alexander E. Patrakov 2004-08-08 23:15:33 UTC
This is probably a duplicate of Bug 1578 and the patch from there should help.
Please test and report the results.
Comment 4 Sergey Svishchev 2004-10-13 14:48:33 UTC
The problem is indeed fixed (tested on 3.0.7).
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:21:44 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.