Bug 965 - samba 3.0 (and 3.0.1) do not work with Netapp CIFS server
samba 3.0 (and 3.0.1) do not work with Netapp CIFS server
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.0
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
: 1313 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 07:10 UTC by Gijs Hollestelle
Modified: 2005-08-24 10:21 UTC (History)
1 user (show)

See Also:


Attachments
add a couple of additional flags to the ntlmssp negoriatneg request (476 bytes, patch)
2004-05-14 12:36 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gijs Hollestelle 2004-01-13 07:10:23 UTC
After and upgrade from Samba 2 to Samba 3.0 i noticed that clients where unable
to connect to homedirectories shared by a Netapp Cifs server. 

The command smbclient //servername/HOME -W workgroup -U user -I server ip, keeps
returning NT_STATUS_LOGON_FAILURE. This apears to be related to the 
client use spnego setting, changing this to client use spnego = no will cause it
to work again.

This bug was confirmed on both linux and FreeBSD.
Comment 1 Gerald (Jerry) Carter 2004-03-18 06:46:17 UTC
Could you provide a raw network capture of the failure 
and the success?  Thanks.
Comment 2 Gerald (Jerry) Carter 2004-03-31 07:20:31 UTC
also, please test 3.0.3pre1
Comment 3 Gerald (Jerry) Carter 2004-05-05 08:01:28 UTC
*** Bug 1313 has been marked as a duplicate of this bug. ***
Comment 4 Gerald (Jerry) Carter 2004-05-14 12:36:57 UTC
Created attachment 512 [details]
add a couple of additional flags to the ntlmssp negoriatneg request

Please try this and see if it fixes the problem with smbclient.
Comment 5 Gijs Hollestelle 2004-06-09 10:12:19 UTC
Sorry for my late reply. It appears that the only netapp i have access to has
been upgraded to a new operating system version, which works regardless of the
spnego setting. As i no longer have access to a system where it didn't work i
can not run any of the tests.
Comment 6 Gerald (Jerry) Carter 2004-10-25 10:51:31 UTC
this is reportedly fixed in recent releases (of smbclient and NetApp's OS).
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:21:59 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.