Bug 9605 - Share not worked by realm name in domain controller
Share not worked by realm name in domain controller
Status: NEW
Product: Samba 4.0
Classification: Unclassified
Component: File services
4.0.1
x64 Linux
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-26 11:07 UTC by Sergey Sidlyarenko
Modified: 2013-05-25 10:14 UTC (History)
1 user (show)

See Also:


Attachments
samba.log (65.77 KB, text/plain)
2013-01-26 11:07 UTC, Sergey Sidlyarenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Sidlyarenko 2013-01-26 11:07:13 UTC
Created attachment 8492 [details]
samba.log

See video: http://www.youtube.com/watch?v=A3rIoAb3pYw&feature=youtu.be&hd=1

joined Windows 7 workstation used staic ip samba internal dns.


/usr/bin/samba-tool domain provision \
   --realm=DC1.LEFOYER.RU --domain=DC1 --host-name=NS1 --host-ip=192.168.100.200 --function-level=2008_R2\
   --adminpass=pa$$word --server-role=dc --dns-backend=SAMBA_INTERNAL -d 3



root@ns1:/home/DC1/administrator# cat /etc/samba/smb.conf
[global]
     netbios name = NS1
     workgroup = DC1
     server string = Samba File Server

     wins support = yes
     dns proxy = yes
     name resolve order = wins bcast host

     interfaces = lo br0
     bind interfaces only = yes

     server role = dc
     server role check:inhibit = yes
     realm = DC1.LEFOYER.RU

     log level = 3
     log file = /var/log/samba/samba.log

     passdb backend = samba4
     idmap_ldb:use rfc2307 = yes
     server services = -nbt -wrepl
     server signing = auto
     dns forwarder = 192.168.101.4
     domain logons = yes
     domain master = yes
     logon path = \\ns1.dc1.lefoyer.ru\profiles\%U
     logon home = \\%N\%U
     logon drive = L:
     logon script = STARTUP.BAT


 [netlogon]
     path = /var/lib/samba/sysvol/dc1.lefoyer.ru/scripts
     browseable = no
     read only = yes

 [sysvol]
     path = /var/lib/samba/sysvol
     read only = no

 [profiles]
     path = /var/lib/samba/profiles
     read only = no

 [homes]
     comment = Домашние каталоги
     path = /home/DC1/%U
     read only = no
     browseable = no
     create mask = 0600
     directory mask = 0700
     vfs objects = acl_xattr full_audit
     full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
     full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename
     root preexec = /etc/samba/mkhomedir.sh %U








root@ns1:/home/DC1/administrator# cat /var/log/samba/samba.log
in attachment
Comment 1 Kai Blin 2013-05-25 10:14:14 UTC
Not sure what this is, but it's not a DNS bug I'd say.