Bug 9547 - Configure does not reliably detect aio_suspend on FreeBSD
Configure does not reliably detect aio_suspend on FreeBSD
Status: RESOLVED DUPLICATE of bug 9546
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
All All
: P5 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on: 9546
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 18:04 UTC by Richard Sharpe
Modified: 2013-01-09 08:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Sharpe 2013-01-07 18:04:37 UTC
+++ This bug was initially created as a clone of Bug #9546 +++

I am finding this problem with configure.in on FreeBSD 8.0

configure:82175: checking for aio_suspend
configure:82187: gcc -o conftest -I/usr/include  -O0 -g -I/home/rsharpe/dev-src/
buildroot/tools/x86_gcc4.2.4/usr/include -DPANZURA_DEV -I/usr/include  -I/home/r
sharpe/dev-src/buildroot/../pixel8/replock -I/home/rsharpe/dev-src/buildroot/bui
ld/cloudcc/build_x86_64/samba-3.6.6/lib/tdb/include -I/home/rsharpe/dev-src/buil
droot/build/cloudcc/build_x86_64/root/usr/include -I/home/rsharpe/dev-src/buildr
oot/build/cloudcc/build_x86_64/tools/x86_gcc4.2.4/usr/include -I/home/rsharpe/de
v-src/buildroot/../pixel8/pz_cifsaudit -Iinclude -I./include  -I. -I. -I./../lib
/replace -I./../lib/tevent -I./librpc -I./.. -I./../lib/popt -I/usr/include -DLD
AP_DEPRECATED   --sysroot /home/rsharpe/dev-src/buildroot/tools/x86_gcc4.2.4 -L/
home/rsharpe/dev-src/buildroot/tools/x86_gcc4.2.4/lib -L/home/rsharpe/dev-src/bu
ildroot/tools/x86_gcc4.2.4/usr/lib -g -L/home/rsharpe/dev-src/buildroot/build/cl
oudcc/build_x86_64/root/lib -L/home/rsharpe/dev-src/buildroot/build/cloudcc/buil
d_x86_64/samba-3.6.6/source3 -L/home/rsharpe/dev-src/buildroot/build/cloudcc/bui
ld_x86_64/samba-3.6.6/source3/bin -L/home/rsharpe/dev-src/buildroot/build/cloudc
c/build_x86_64/pz_cifsaudit -L/home/rsharpe/dev-src/buildroot/build/cloudcc/buil
d_x86_64/licd/build/FreeBSD/export/dist/lib -rpath /home/rsharpe/dev-src/buildro
ot/tools/x86_gcc4.2.4/lib -rpath /home/rsharpe/dev-src/buildroot/tools/x86_gcc4.
2.4/usr/lib -L./bin -L/usr/lib conftest.c  -lexecinfo -liconv -lrt >&5
conftest.c: In function 'main':
conftest.c:2: error: 'NULL' undeclared (first use in this function)
conftest.c:2: error: (Each undeclared identifier is reported only once
conftest.c:2: error: for each function it appears in.)
conftest.c:2: warning: passing argument 1 of 'aio_suspend' from incompatible poi
nter type
configure:82194: $? = 1
configure: failed program was:
| #include <aio.h>
| int main() { struct aiocb a; return aio_suspend(&a, 1, NULL); }
configure:82212: result: no
Comment 1 Richard Sharpe 2013-01-07 18:05:03 UTC
See bug 9546 for a patch.
Comment 2 Karolin Seeger 2013-01-09 08:38:28 UTC

*** This bug has been marked as a duplicate of bug 9546 ***