Bug 946 - 3.0.1(starting with rc1?) gives errors to machines accessing other machines through domain
3.0.1(starting with rc1?) gives errors to machines accessing other machines t...
Status: RESOLVED DUPLICATE of bug 936
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
All Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2004-01-07 08:14 UTC by John H.
Modified: 2005-11-14 09:31 UTC (History)
1 user (show)

See Also:

TKdiff Output (59.99 KB, text/plain)
2004-01-13 06:30 UTC, Markus Greil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John H. 2004-01-07 08:14:17 UTC
SOLUTION:downgrade to 3.0.0-fixed it for me.


EXACT same problem as

I have samba 3.0.1-1 rpms and fedora core 1.

Samba is set as a WINS server, which the win2k machines, who use DHCP from
router, are pointed to by the WINS server address specified in router(each of
the win2k machines, via ipconfig /all reveal they do in fact use the wins server).

At different times, and different machines, the win2k clients get one of the two
"\\computer not accessible. the system cannot find message text for message
number 0x%1 in the message file for %2"


"\\computer is not accessible
an internal windows 2000 error occurred"

while these unaccessible computers generate this message, if i try from the
linux machine for the same \\machine, i get
session setup failed: NT code 0xf90a8141
via smbclient -L \\machine -U user

later, it is accessible. it keeps going on and off.
Comment 1 Olaf Kroeger 2004-01-08 02:43:54 UTC
I have the same symptoms (also not continuosly, but maybe 2/3 of the time) with
Samba 3.0.1 running on Sparc-Solaris 8 and without DHCP (WINS Server entered
directly in Windows System Properties). Additional to W2K clients the error
messages appear also on W2K3 member servers, not only while using Network
Neighbourhood, but also after trying to map a new drive letter to a network
share via Windows Explorer or "net use". Once mapped, the shares can always be
accessed. On W2K3, the Network Neighbourhood ist often blank and stays that way
even after a "net use" has succeeded.

Comment 2 saju john 2004-01-13 03:24:40 UTC
I upgraded samba Samba 3.0.1pre3 to Samba 3.0.1rc1
.The problem is that when accessing computers through
Network neighbourhood it is giving an error message

\\comp1(computer name of the accessed computer)is not
The system cannot find message test for the message
number 0x%1 in the message file for %2.

but after some time if I access the same machine it
will show some other error message.

\\comp1(computer name of the accessed computer) is not
An internal windows 2000 error occured.

But again after some time,when I access the same
machine it will open without any error message.

This problem is changing for each machine.When one
machine become OK other start showing the error

This started after upgrading form Samba 3.0.1pre3 to 
Samba 3.0.1rc1  only.

The Network is samba PDC domain
saju john

Comment 3 Markus Greil 2004-01-13 06:30:46 UTC
Created attachment 359 [details]
TKdiff Output 

This tkdiff output shows the difference between a working session of smbclient
to a failed one.

left column (working): 
zerberus:/var/lib/samba # smbclient  -W GCD_HS -U administrator -L  //pippin

	Sharename      Type	 Comment
	---------      ----	 -------
	IPC$	       IPC	 Remote-IPC
	ADMIN$	       Disk	 Remoteadmin
	C$	       Disk	 Standardfreigabe

	Server		     Comment
	---------	     -------

	Workgroup	     Master
	---------	     -------

right column (failed):
zerberus:/var/lib/samba # smbclient  -W GCD_HS -U administrator -L  //pippin
session setup failed: NT code 0xe5df5a5d
Comment 4 Markus Greil 2004-01-13 06:43:10 UTC
Additional information to "Additional Comment #3":

We use Samba 3.0.2pre1 and ldap.

log level = 2 passdb:10 sam:10 auth:10 
Comment 5 Gerald (Jerry) Carter 2004-01-14 21:03:42 UTC
I've seen this before but it was due to 
a broken domain trust relationship.  I need a full
level 10 debug log from the server to figure out 
what the problem is.  IIRC the windows 2000 DC
was sending back a corrupted packet.
Comment 6 Gerald (Jerry) Carter 2004-01-14 21:24:38 UTC

*** This bug has been marked as a duplicate of 936 ***
Comment 7 John H. 2004-01-14 22:58:53 UTC
I'm sorry, but I looked at 936 and don't see the same symptoms I was having. 
You are sure it is the same, and fixed for rc1?
Comment 8 Gerald (Jerry) Carter 2004-01-15 05:48:33 UTC
Yup.  I'm pretty sure this is the same schannel bug.  The 
tell-tale sign was the currupted error code returned.
Comment 9 saju john 2004-01-22 00:55:41 UTC
Ya. this problem is corrected on 3.0.2rc1
Comment 10 Gerald (Jerry) Carter 2005-11-14 09:31:28 UTC
database cleanup