Bug 9452 - [RFE] libsmbclient: parse out and use the port information out of the URL
[RFE] libsmbclient: parse out and use the port information out of the URL
Status: RESOLVED DUPLICATE of bug 9796
Product: Samba 4.0
Classification: Unclassified
Component: libsmbclient
All Linux
: P5 enhancement
: ---
Assigned To: Samba QA Contact
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2012-12-03 16:23 UTC by Tomas Bzatek
Modified: 2013-04-16 17:25 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Bzatek 2012-12-03 16:23:40 UTC
Would be nice to have a way for connecting to a server running on non-standard port. One use case is for local non-privileged clients testing and the other is to be able to connect to userspace smb servers on restricted systems (like mobile devices).

For now, constructing a URL like 'smb://localhost:1445/public/' would lead to an error when trying to resolve the server address:

> smbc_stat(smb://localhost:1445/public)
> SMBC_server: server_n=[localhost:1445] server=[localhost:1445]
>  -> server_n=[localhost:1445] server=[localhost:1445]
> internal_resolve_name: looking up localhost:1445#20 (sitename (null))
> no entry for localhost:1445#20 found.
> resolve_hosts: Attempting host lookup for name localhost:1445<0x20>
> resolve_hosts: getaddrinfo failed for name localhost:1445 [Name or service not known]

Tested on samba-3.6.9
Comment 1 Jeremy Allison 2013-04-16 17:25:10 UTC

*** This bug has been marked as a duplicate of bug 9796 ***