Bug 9363 - Join a samba4 domain as a DC problems
Join a samba4 domain as a DC problems
Product: Samba 4.0
Classification: Unclassified
x64 Linux
: P5 major
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
Blocks: 9306
  Show dependency treegraph
Reported: 2012-11-06 15:34 UTC by Marc Muehlfeld
Modified: 2012-11-14 21:20 UTC (History)
1 user (show)

See Also:

Output of the domain join command (3.10 KB, text/plain)
2012-11-06 15:34 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2012-11-06 15:34:16 UTC
Created attachment 8161 [details]
Output of the domain join command

I have one samba4 rc4 DC + Bind and I want to join a second machine (also s4 rc4 + Bind) as DC to the domain. I followed the wiki (http://wiki.samba.org/index.php/Samba4/HOWTO/Join_a_domain_as_a_DC).

I joined the domain with the following command (this differs from the wiki, because there is not mentioned yet, that Bind isn't default any more):
# samba-tool domain join muc.medizinische-genetik.de DC -Uadministrator --realm=muc.medizinische-genetik.de --dns-backend=BIND9_DLZ
I attached the output of the command. For me it looks OK.

Now when I run 'samba-tool drs showrepl' as told in the wiki, on the new joined DC, I get:

# samba-tool drs showrepl
ERROR(<class 'samba.drs_utils.drsException'>): DRS connection to test_dc2.muc.medizinische-genetik.de failed - drsException: DRS connection to test_dc2.muc.medizinische-genetik.de failed: (-1073741772, 'NT_STATUS_OBJECT_NAME_NOT_FOUND')
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/drs.py", line 39, in drsuapi_connect
    (ctx.drsuapi, ctx.drsuapi_handle, ctx.bind_supported_extensions) = drs_utils.drsuapi_connect(ctx.server, ctx.lp, ctx.creds)
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/drs_utils.py", line 54, in drsuapi_connect
    raise drsException("DRS connection to %s failed: %s" % (server, e))

If I run the command on the old DC I get:
# samba-tool drs showrepl
DSA Options: 0x00000001
DSA object GUID: 25e33532-42f2-4082-b9f4-072f9108b565
DSA invocationId: cb1d70fc-1110-4e28-8af9-d9e1cd064995


ERROR(runtime): DsReplicaGetInfo of type 0 failed - (-1073610723, 'NT_STATUS_RPC_PROTOCOL_ERROR')

It seems currently the required DNS entries are not created to join a s4 machine as DC to an existing (samba4) domain.

Please let me know if I can provide you any logs/outputs.
Comment 1 Marc Muehlfeld 2012-11-14 21:20:54 UTC
This was a resulting problem out of an other issue:

The solution for that was found and the domain join works fine.

I updated the Join as DC wiki page and added an addition section about this DNS issue that is caused by lost hard-linking:

So this wasn't a real bug. It was just a result of broken samba DNS because of lost hard links.