Bug 9334 - Samba 4.0 RC won't build on OpenIndiana
Samba 4.0 RC won't build on OpenIndiana
Status: RESOLVED WORKSFORME
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
x64 Other
: P5 regression
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks: 8622
  Show dependency treegraph
 
Reported: 2012-10-29 15:10 UTC by feldspar
Modified: 2015-02-20 02:19 UTC (History)
3 users (show)

See Also:


Attachments
pkg list for the OI 151a7 VM ira built on. (48.65 KB, text/plain)
2012-11-14 18:11 UTC, Ira Cooper
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description feldspar 2012-10-29 15:10:35 UTC
# make
WAF_MAKE=1 ./buildtools/bin/waf build
Waf: Entering directory `/home/openindiana/samba-4.0.0rc3/bin'
    Selected embedded Heimdal build
[   6/3353] Generating VERSION
[  23/3353] Generating smbd/build_options.c
[ 490/3353] Compiling lib/addns/dnsrecord.c
In file included from ../lib/replace/system/gssapi.h:43,
                 from ../lib/addns/dns.h:31,
                 from ../lib/addns/dnsrecord.c:24:
../gssapi/gssapi_krb5.h:56: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘extern’
../gssapi/gssapi_krb5.h:63: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘GSSAPI_LIB_VARIABLE’
../gssapi/gssapi_krb5.h:79: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:84: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:87: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:90: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:95: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:102: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:107: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:114: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:122: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:126: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:129: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:134: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:138: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:142: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:147: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:150: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:159: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:169: error: expected specifier-qualifier-list before ‘OM_uint32’
../gssapi/gssapi_krb5.h:175: error: expected specifier-qualifier-list before ‘OM_uint32’
../gssapi/gssapi_krb5.h:181: error: expected specifier-qualifier-list before ‘OM_uint32’
../gssapi/gssapi_krb5.h:187: error: expected specifier-qualifier-list before ‘OM_uint32’
../gssapi/gssapi_krb5.h:198: error: expected specifier-qualifier-list before ‘OM_uint32’
../gssapi/gssapi_krb5.h:205: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:212: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
../gssapi/gssapi_krb5.h:217: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘OM_uint32’
In file included from ../lib/replace/system/gssapi.h:47,
                 from ../lib/addns/dns.h:31,
                 from ../lib/addns/dnsrecord.c:24:
../gssapi/gssapi_spnego.h:41: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘GSSAPI_CPP_START’
In file included from /usr/include/fcntl.h:40,
                 from ../lib/addns/dns.h:41,
                 from ../lib/addns/dnsrecord.c:24:
/usr/include/sys/fcntl.h:199: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘typedef’
In file included from ../lib/addns/dnsrecord.c:24:
../lib/addns/dns.h:353: error: expected declaration specifiers or ‘...’ before ‘OM_uint32’
../lib/addns/dns.h:353: error: expected declaration specifiers or ‘...’ before ‘OM_uint32’
../lib/addns/dns.h:357: error: expected declaration specifiers or ‘...’ before ‘gss_ctx_id_t’
../lib/addns/dns.h:360: error: expected declaration specifiers or ‘...’ before ‘gss_ctx_id_t’
Waf: Leaving directory `/home/openindiana/samba-4.0.0rc3/bin'
Build failed:  -> task failed (err #1):
        {task: cc dnsrecord.c -> dnsrecord_1.o}
make: *** [all] Error 1
Comment 1 Matthieu Patou 2012-10-30 04:29:43 UTC
Ira can you provide us with an image for open-indiana ?

Without it will be very hard to get this solved.
Comment 2 Ira Cooper 2012-10-30 09:27:41 UTC
(In reply to comment #1)
> Ira can you provide us with an image for open-indiana ?
> 
> Without it will be very hard to get this solved.

http://openindiana.org/

Likely we have the same issue on Solaris 11.  That's why I marked it a blocker.  This issue will hit many Solaris users.
Comment 3 Andrew Bartlett 2012-10-30 22:04:32 UTC
What configure line was used for this build?

The build farm shows that the waf build does build on OpenIndiana:
https://build.samba.org/build.cgi/host/openindiana so I don't think this is a generic issue.
Comment 4 feldspar 2012-10-31 09:18:54 UTC
(In reply to comment #3)
> What configure line was used for this build?
> 
> The build farm shows that the waf build does build on OpenIndiana:
> https://build.samba.org/build.cgi/host/openindiana so I don't think this is a
> generic issue.

Just plain ./configure

compiler is gcc 4.4.4
Comment 5 feldspar 2012-10-31 10:43:07 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > What configure line was used for this build?
> > 
> > The build farm shows that the waf build does build on OpenIndiana:
> > https://build.samba.org/build.cgi/host/openindiana so I don't think this is a
> > generic issue.
> 
> Just plain ./configure
> 
> compiler is gcc 4.4.4

I followed https://build.samba.org/build.cgi/build/7629585c05573b5709e52f368bfdf6ffb9967401 and switched to Sun Studio 12u1 with GNU cpp, now I get this:


[3332/3674] Linking default/source4/librpc/libdcerpc.so
[3333/3674] Linking default/source4/librpc/libdcerpc-atsvc.so
cc: standard input (-) valid only for preprocessor
Waf: Leaving directory `/home/openindiana/samba-4.0.0rc4/bin'
Build failed:  -> task failed (err #1):
        {task: cc_link  -> libdcerpc-atsvc.so}
make: *** [all] Error 1
Comment 6 feldspar 2012-10-31 11:21:21 UTC
Looks like there's a trailing dash when there shouldn't be, or a command got cut off:

22:14:26 task task
        {task: cc_link  -> libdcerpc-samr.so} must run as it was never run before or the task code changed
[3336/3674] Linking default/source4/librpc/libdcerpc-samr.so
22:14:26 runner cc -o /home/openindiana/samba-4.0.0rc4/bin/default/source4/librpc/libdcerpc-samr.so -lpthread -G -Wl,-h,libdcerpc-samr.so.0 -Wl,-zignore -Wl,-zcombreloc -Wl,-Bdirect -L. -L/usr/gnu/lib -Ldefault/auth -Ldefault/libcli/ldap -Ldefault/libds/common -Ldefault/lib/tdb -Ldefault/lib/socket -Ldefault/source4/libcli/ldap -Ldefault/lib/dbwrap -Ldefault/lib/ldb-samba -Ldefault/source4/auth/kerberos -Ldefault/lib/tdb_wrap -Ldefault/lib/krb5_wrap -Ldefault/source4/dsdb -Ldefault/lib/ldb -Ldefault/lib -Ldefault/lib/talloc -Ldefault/libcli/smb -Ldefault/source4/lib/socket -Ldefault/libcli/cldap -Ldefault/lib/tevent -Ldefault/auth/gensec -Ldefault/source4/lib/events -Ldefault/libcli/security -Ldefault/lib/param -Ldefault/libcli/util -Ldefault/libcli/auth -Ldefault/auth/credentials -Ldefault/lib/util -Ldefault/source4/libcli -Ldefault/source4/heimdal_build -Ldefault/libcli/nbt -Ldefault/lib/addns -Ldefault/lib/replace -Ldefault/lib/nss_wrapper -Ldefault/librpc -Ldefault/lib/uid_wrapper -Ldefault/source4/librpc -Ldefault/lib/socket_wrapper -L/usr/local/lib -L/usr/lib -Bdynamic -lsocket_wrapper -ldcerpc -luid_wrapper -ldcerpc-samba -lndr-standard -lnss_wrapper -lreplace -laddns -lcli-nbt -lroken-samba4 -lsmbclient-raw -ltevent-util -lsamba-credentials -lndr-samba -lcliauth -lerrors -lsamba-hostconfig -lsamba-security -lndr-nbt -ldcerpc-binding -levents -lgensec -lsamba-util -ltevent -lcli_cldap -lnetif -lcli_smb_common -ltalloc -lsamba-sockets -lndr -lutil_setid -lgssapi-samba4 -lldb -lsamdb-common -lcom_err-samba4 -lkrb5samba -ltdb-wrap -lauthkrb5 -lldbsamba -ldbwrap -lutil_tdb -lasn1util -lndr-krb5pac -lserver-role -lsamba-modules -lsamdb -lcli-ldap -linterfaces -lsmb_transport -lkrb5-samba4 -lasn1-samba4 -lhcrypto-samba4 -lwind-samba4 -ltdb -lflag_mapping -lcli-ldap-common -lauth_sam_reply -lpyldb-util -lheimbase-samba4 -lhx509-samba4 -lresolv -lintl -lz -lgnutls -lgcrypt -lm -lsocket -lnsl -ldl -lpython2.6 -lrt -
cc: standard input (-) valid only for preprocessor
Waf: Leaving directory `/home/openindiana/samba-4.0.0rc4/bin'
Build failed:  -> task failed (err #1):
        {task: cc_link  -> libdcerpc-samr.so}
  File "./buildtools/bin/waf", line 76, in <module>
        Scripting.prepare(t, cwd, VERSION, wafdir)
  File "/home/openindiana/samba-4.0.0rc4/buildtools/wafadmin/Scripting.py", line 147, in prepare
        error(str(e))
make: *** [all] Error 1
Comment 7 feldspar 2012-11-05 15:17:58 UTC
I tried this with slightly different results:

$ CPP="/opt/gcc/4.4.4/bin/cpp" make
WAF_MAKE=1 ./buildtools/bin/waf build
Waf: Entering directory `/home/openindiana/samba-4.0.0rc4/bin'
    Selected embedded Heimdal build
[   7/3662] Generating VERSION
[  42/3662] Generating smbd/build_options.c
[3316/3662] Linking default/source3/libsecrets3.so
[3317/3662] Linking default/source3/libcli_spoolss.so
[3319/3662] Linking default/source3/libprinting_migrate.so
[3320/3662] Linking default/source3/libsmbldap.so
[3321/3662] Linking default/source3/winbindd/libnss_info.so
[3322/3662] Linking default/source3/libutil_cmdline.so
[3324/3662] Linking default/source3/libsmbldaphelper.so
[3325/3662] Linking default/source3/pys3param.so
[3326/3662] Linking default/source3/liblibcli_netlogon3.so
[3329/3662] Linking default/source3/libpopt_samba3.so
[3330/3662] Linking default/source3/winbindd/libnss-info-hash.so
[3331/3662] Linking default/source3/libgse.so
[3332/3662] Linking default/lib/ldb-samba/libldb-ildap.so
[3334/3662] Linking default/source3/liblibsmb.so
[3335/3662] Linking default/source3/libpdb.so
[3336/3662] Linking default/source3/libmsrpc3.so
[3337/3662] Linking default/source3/libsmb/libsmbclient.so
[3338/3662] Linking default/source3/pylibsmb.so
[3339/3662] Linking default/source3/winbindd/libidmap.so
[3340/3662] Linking default/source3/pam_smbpass/libpamsmbpass.so
[3341/3662] Linking default/source3/winbindd/libidmap-rid.so
[3342/3662] Linking default/source3/winbindd/libidmap-hash.so
[3343/3662] Linking default/source4/lib/registry/libregistry.so
[3344/3662] Linking default/source3/libtrusts_util.so
[3345/3662] Linking default/source4/librpc/libdcerpc-samba4.so
[3346/3662] Linking default/source3/libads.so
[3347/3662] Linking default/source4/librpc/libdcerpc-samr.so
cc: standard input (-) valid only for preprocessor
Waf: Leaving directory `/home/openindiana/samba-4.0.0rc4/bin'
Build failed:  -> task failed (err #1):
        {task: cc_link  -> libdcerpc-samr.so}
make: *** [all] Error 1

$ CPP="/opt/gcc/4.4.4/bin/cpp" make V=3
...
02:16:19 envhash 'oW\xdb\x08\x0f\x9f\x01\xc64hU\x8c/\xad\xc4^' ["['/usr/bin/cc']", '', "['-o', '']", "['-lpthread', '-G', '-Wl,-h,libdcerpc-samr.so.0', '-Wl,-zignore', '-Wl,-zcombreloc', '-Wl,-Bdirect', '-L.', '-L/usr/gnu/lib', '-Ldefault/auth', '-Ldefault/libcli/ldap', '-Ldefault/libds/common', '-Ldefault/lib/tdb', '-Ldefault/lib/socket', '-Ldefault/source4/libcli/ldap', '-Ldefault/lib/krb5_wrap', '-Ldefault/source4/auth/kerberos', '-Ldefault/lib/ldb-samba', '-Ldefault/lib/dbwrap', '-Ldefault/lib/tdb_wrap', '-Ldefault/source4/dsdb', '-Ldefault/lib/ldb', '-Ldefault/lib/replace', '-Ldefault/lib', '-Ldefault/libcli/smb', '-Ldefault/source4/lib/socket', '-Ldefault/libcli/cldap', '-Ldefault/auth/gensec', '-Ldefault/source4/lib/events', '-Ldefault/libcli/util', '-Ldefault/libcli/auth', '-Ldefault/lib/param', '-Ldefault/auth/credentials', '-Ldefault/lib/util', '-Ldefault/source4/libcli', '-Ldefault/source4/heimdal_build', '-Ldefault/libcli/nbt', '-Ldefault/lib/addns', '-Ldefault/libcli/security', '-Ldefault/lib/tevent', '-Ldefault/lib/talloc', '-Ldefault/source4/librpc', '-Ldefault/librpc', '-L/usr/local/lib', '-L/usr/lib', '-Bdynamic', '-ldcerpc-samba', '-lndr-standard', '-ldcerpc', '-ldcerpc-binding', '-ltalloc', '-lndr-samba', '-ltevent', '-lndr', '-lsamba-security', '-lndr-nbt', '-laddns', '-lcli-nbt', '-lroken-samba4', '-lsmbclient-raw', '-ltevent-util', '-lsamba-credentials', '-lsamba-hostconfig', '-lcliauth', '-lerrors', '-levents', '-lgensec', '-lsamba-util', '-lcli_cldap', '-lnetif', '-lcli_smb_common', '-lsamba-sockets', '-lreplace', '-lndr-krb5pac', '-lasn1util', '-lgssapi-samba4', '-lldb', '-lsamdb-common', '-lcom_err-samba4', '-ltdb-wrap', '-ldbwrap', '-lutil_tdb', '-lldbsamba', '-lauthkrb5', '-lkrb5samba', '-lserver-role', '-lsamba-modules', '-lsamdb', '-lutil_setid', '-lcli-ldap', '-linterfaces', '-lsmb_transport', '-lkrb5-samba4', '-lasn1-samba4', '-lhcrypto-samba4', '-lwind-samba4', '-ltdb', '-lflag_mapping', '-lcli-ldap-common', '-lpyldb-util', '-lauth_sam_reply', '-lheimbase-samba4', '-lhx509-samba4', '-lintl', '-lm', '-lsocket', '-lnsl', '-ldl', '-lpython2.6', '-lgnutls', '-lgcrypt', '-lresolv', '-lrt', '-lz']"]
02:16:19 task task
        {task: cc_link  -> libdcerpc-samr.so} must run as it was never run before or the task code changed
[3326/3662] Linking default/source4/librpc/libdcerpc-samr.so
02:16:19 runner /usr/bin/cc -o /home/openindiana/samba-4.0.0rc4/bin/default/source4/librpc/libdcerpc-samr.so -lpthread -G -Wl,-h,libdcerpc-samr.so.0 -Wl,-zignore -Wl,-zcombreloc -Wl,-Bdirect -L. -L/usr/gnu/lib -Ldefault/auth -Ldefault/libcli/ldap -Ldefault/libds/common -Ldefault/lib/tdb -Ldefault/lib/socket -Ldefault/source4/libcli/ldap -Ldefault/lib/krb5_wrap -Ldefault/source4/auth/kerberos -Ldefault/lib/ldb-samba -Ldefault/lib/dbwrap -Ldefault/lib/tdb_wrap -Ldefault/source4/dsdb -Ldefault/lib/ldb -Ldefault/lib/replace -Ldefault/lib -Ldefault/libcli/smb -Ldefault/source4/lib/socket -Ldefault/libcli/cldap -Ldefault/auth/gensec -Ldefault/source4/lib/events -Ldefault/libcli/util -Ldefault/libcli/auth -Ldefault/lib/param -Ldefault/auth/credentials -Ldefault/lib/util -Ldefault/source4/libcli -Ldefault/source4/heimdal_build -Ldefault/libcli/nbt -Ldefault/lib/addns -Ldefault/libcli/security -Ldefault/lib/tevent -Ldefault/lib/talloc -Ldefault/source4/librpc -Ldefault/librpc -L/usr/local/lib -L/usr/lib -Bdynamic -ldcerpc-samba -lndr-standard -ldcerpc -ldcerpc-binding -ltalloc -lndr-samba -ltevent -lndr -lsamba-security -lndr-nbt -laddns -lcli-nbt -lroken-samba4 -lsmbclient-raw -ltevent-util -lsamba-credentials -lsamba-hostconfig -lcliauth -lerrors -levents -lgensec -lsamba-util -lcli_cldap -lnetif -lcli_smb_common -lsamba-sockets -lreplace -lndr-krb5pac -lasn1util -lgssapi-samba4 -lldb -lsamdb-common -lcom_err-samba4 -ltdb-wrap -ldbwrap -lutil_tdb -lldbsamba -lauthkrb5 -lkrb5samba -lserver-role -lsamba-modules -lsamdb -lutil_setid -lcli-ldap -linterfaces -lsmb_transport -lkrb5-samba4 -lasn1-samba4 -lhcrypto-samba4 -lwind-samba4 -ltdb -lflag_mapping -lcli-ldap-common -lpyldb-util -lauth_sam_reply -lheimbase-samba4 -lhx509-samba4 -lintl -lm -lsocket -lnsl -ldl -lpython2.6 -lgnutls -lgcrypt -lresolv -lrt -lz -
cc: standard input (-) valid only for preprocessor
Waf: Leaving directory `/home/openindiana/samba-4.0.0rc4/bin'
Build failed:  -> task failed (err #1):
        {task: cc_link  -> libdcerpc-samr.so}
  File "./buildtools/bin/waf", line 76, in <module>
        Scripting.prepare(t, cwd, VERSION, wafdir)
  File "/home/openindiana/samba-4.0.0rc4/buildtools/wafadmin/Scripting.py", line 147, in prepare
        error(str(e))
make: *** [all] Error 1
Comment 8 Karolin Seeger 2012-11-06 09:39:43 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Ira can you provide us with an image for open-indiana ?
> > 
> > Without it will be very hard to get this solved.
> 
> http://openindiana.org/
> 
> Likely we have the same issue on Solaris 11.  That's why I marked it a blocker.
>  This issue will hit many Solaris users.

Ira, would you like to investigate?
Comment 9 Ira Cooper 2012-11-06 13:05:44 UTC
(In reply to comment #8)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Ira can you provide us with an image for open-indiana ?
> > > 
> > > Without it will be very hard to get this solved.
> > 
> > http://openindiana.org/
> > 
> > Likely we have the same issue on Solaris 11.  That's why I marked it a blocker.
> >  This issue will hit many Solaris users.
> 
> Ira, would you like to investigate?

The issues are very platform specific.  (Realize, I build S3/S4 on Illumos.  But I rebuild most of the libraries that underpin Samba.)

When I tested RC4, on a VM I built last night, I got to where it should link, and the linking was a disaster.  I need to spend some time making sure that the right linker etc are in place.  I suspect that the autoconf build work if there was a modern enough kerberos in place.  But I haven't tried it.
Comment 10 Andrew Bartlett 2012-11-14 08:02:15 UTC
On the linking issue (this bug has two parts, the gssapi header issue and the linking issue), on Fedora Linux I get:

[3567/4085] Linking default/source4/librpc/libdcerpc-samr.so
18:53:01 runner ccache gcc -o /data/samba/git/samba4/bin/default/source4/librpc/libdcerpc-samr.so -Wl,-no-undefined -Wl,--export-dynamic -lpthread -Wl,--as-needed -shared -Wl,--version-script=/data/samba/git/samba4/bin/default/source4/librpc/dcerpc-samr.vscript -Wl,-h,libdcerpc-samr.so.0 -Wl,-z,relro -Wl,-rpath,/data/samba/git/samba4/bin/shared -Wl,-rpath,/data/samba/git/samba4/bin/shared/private -Ldefault/auth -Ldefault/libcli/ldap -Ldefault/libds/common -Ldefault/lib/tdb -Ldefault/lib/socket -Ldefault/source4/libcli/ldap -Ldefault/lib/ldb-samba -Ldefault/lib/dbwrap -Ldefault/source4/auth/kerberos -Ldefault/lib/tdb_wrap -Ldefault/lib/krb5_wrap -Ldefault/source4/dsdb -Ldefault/lib/ldb -Ldefault/lib -Ldefault/lib/talloc -Ldefault/libcli/smb -Ldefault/source4/lib/socket -Ldefault/libcli/cldap -Ldefault/lib/tevent -Ldefault/auth/gensec -Ldefault/source4/lib/events -Ldefault/libcli/security -Ldefault/lib/param -Ldefault/libcli/util -Ldefault/libcli/auth -Ldefault/auth/credentials -Ldefault/lib/util -Ldefault/source4/libcli -Ldefault/source4/heimdal_build -Ldefault/libcli/nbt -Ldefault/lib/addns -Ldefault/lib/replace -Ldefault/lib/nss_wrapper -Ldefault/librpc -Ldefault/lib/uid_wrapper -Ldefault/source4/librpc -Ldefault/lib/socket_wrapper -L/usr/local/lib -L/usr/lib64 -Wl,-Bdynamic -lsocket_wrapper -ldcerpc -luid_wrapper -ldcerpc-samba -lndr-standard -lnss_wrapper -lreplace -laddns -lcli-nbt -lroken-samba4 -lsmbclient-raw -ltevent-util -lsamba-credentials -lndr-samba -lcliauth -lerrors -lsamba-hostconfig -lsamba-security -lndr-nbt -ldcerpc-binding -levents -lgensec -lsamba-util -ltevent -lcli_cldap -lnetif -lcli_smb_common -ltalloc -lsamba-sockets -lndr -lutil_setid -lgssapi-samba4 -lldb -lsamdb-common -lkrb5samba -ltdb-wrap -lauthkrb5 -ldbwrap -lldbsamba -lutil_tdb -lasn1util -lndr-krb5pac -lserver-role -lsamba-modules -lsamdb -lcli-ldap -linterfaces -lsmb_transport -lkrb5-samba4 -lasn1-samba4 -lhcrypto-samba4 -lwind-samba4 -ltdb -lflag_mapping -lcli-ldap-common -lauth_sam_reply -lpyldb-util -lheimbase-samba4 -lhx509-samba4 -lresolv -lcom_err -lutil -lsasl2 -lz -lgnutls -lgcrypt -lm -ldl -lpython2.7 -lcrypt -lbsd -lattr -lnsl -lrt
18:53:01 envhash '\xc2,\x16\xd5Fx\x17\xb3M`\xb4/\xaa0\xa6\x0c' ["['ccache', 'gcc']", '', "['-o', '']", "['-Wl,-no-undefined', '-Wl,--export-dynamic', '-lpthread', '-Wl,--as-needed', '-shared', '-Wl,--version-script=/data/samba/git/samba4/bin/default/source4/librpc/dcerpc-atsvc.vscript', '-Wl,-h,libdcerpc-atsvc.so.0', '-Wl,-z,relro', '-Wl,-rpath,/data/samba/git/samba4/bin/shared', '-Wl,-rpath,/data/samba/git/samba4/bin/shared/private', '-Ldefault/auth', '-Ldefault/libcli/ldap', '-Ldefault/libds/common', '-Ldefault/lib/tdb', '-Ldefault/lib/socket', '-Ldefault/source4/libcli/ldap', '-Ldefault/lib/ldb-samba', '-Ldefault/lib/dbwrap', '-Ldefault/source4/auth/kerberos', '-Ldefault/lib/tdb_wrap', '-Ldefault/lib/krb5_wrap', '-Ldefault/source4/dsdb', '-Ldefault/lib/ldb', '-Ldefault/lib', '-Ldefault/lib/talloc', '-Ldefault/libcli/smb', '-Ldefault/source4/lib/socket', '-Ldefault/libcli/cldap', '-Ldefault/lib/tevent', '-Ldefault/auth/gensec', '-Ldefault/source4/lib/events', '-Ldefault/libcli/security', '-Ldefault/lib/param', '-Ldefault/libcli/util', '-Ldefault/libcli/auth', '-Ldefault/auth/credentials', '-Ldefault/lib/util', '-Ldefault/source4/libcli', '-Ldefault/source4/heimdal_build', '-Ldefault/libcli/nbt', '-Ldefault/lib/addns', '-Ldefault/lib/replace', '-Ldefault/lib/nss_wrapper', '-Ldefault/librpc', '-Ldefault/lib/uid_wrapper', '-Ldefault/source4/librpc', '-Ldefault/lib/socket_wrapper', '-L/usr/local/lib', '-L/usr/lib64', '-Wl,-Bdynamic', '-lsocket_wrapper', '-ldcerpc', '-luid_wrapper', '-ldcerpc-samba', '-lndr-standard', '-lnss_wrapper', '-lreplace', '-laddns', '-lcli-nbt', '-lroken-samba4', '-lsmbclient-raw', '-ltevent-util', '-lsamba-credentials', '-lndr-samba', '-lcliauth', '-lerrors', '-lsamba-hostconfig', '-lsamba-security', '-lndr-nbt', '-ldcerpc-binding', '-levents', '-lgensec', '-lsamba-util', '-ltevent', '-lcli_cldap', '-lnetif', '-lcli_smb_common', '-ltalloc', '-lsamba-sockets', '-lndr', '-lutil_setid', '-lgssapi-samba4', '-lldb', '-lsamdb-common', '-lkrb5samba', '-ltdb-wrap', '-lauthkrb5', '-ldbwrap', '-lldbsamba', '-lutil_tdb', '-lasn1util', '-lndr-krb5pac', '-lserver-role', '-lsamba-modules', '-lsamdb', '-lcli-ldap', '-linterfaces', '-lsmb_transport', '-lkrb5-samba4', '-lasn1-samba4', '-lhcrypto-samba4', '-lwind-samba4', '-ltdb', '-lflag_mapping', '-lcli-ldap-common', '-lauth_sam_reply', '-lpyldb-util', '-lheimbase-samba4', '-lhx509-samba4', '-lresolv', '-lcom_err', '-lutil', '-lsasl2', '-lz', '-lgnutls', '-lgcrypt', '-lm', '-ldl', '-lpython2.7', '-lcrypt', '-lbsd', '-lattr', '-lnsl', '-lrt']"]
18:53:01 Logs Task 

That is, in particular I don't get the trailing "-".

The thing that is special about libdcerpc-samr is that is is a library of (private) libraries, but has no .o files itself.  The role is to be a public library providing some interfaces for (I think) OpenChange.
Comment 11 Ira Cooper 2012-11-14 18:10:20 UTC
You have some other issues.

I currently have it compiling and linking with GCC 4.4.4.

PATH=/opt/gcc/4.4.4/bin:$PATH ./configure --with-ad
PATH=/opt/gcc/4.4.4/bin:$PATH make -j8

I've done 0 tests on the resulting build.  But "it works here."

Note, I did my builds as root.

I'll be attaching the pkg list output from my VM.  You need GCC 4.4.4.  4.3.2 will fail.

Thanks,
Comment 12 Ira Cooper 2012-11-14 18:11:28 UTC
Created attachment 8192 [details]
pkg list for the OI 151a7 VM ira built on.
Comment 13 Andrew Bartlett 2012-11-14 20:07:10 UTC
(In reply to comment #11)
> You have some other issues.
> 
> I currently have it compiling and linking with GCC 4.4.4.
> 
> PATH=/opt/gcc/4.4.4/bin:$PATH ./configure --with-ad
> PATH=/opt/gcc/4.4.4/bin:$PATH make -j8
> 
> I've done 0 tests on the resulting build.  But "it works here."
> 
> Note, I did my builds as root.
> 
> I'll be attaching the pkg list output from my VM.  You need GCC 4.4.4.  4.3.2
> will fail.
> 
> Thanks,

Ira,

I'm not sure if you were referring to me, but the logs I gave were from successful Fedora builds.  I was trying to provide background details for analysis between working and not-working builds.

Andrew Bartlett