Bug 9185 - Winbind cannot resolve AD DC in a different subnet
Winbind cannot resolve AD DC in a different subnet
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Winbind
4.0.0rc1
All All
: P5 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
: 9230 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 11:32 UTC by Sumit Bose
Modified: 2014-09-17 13:15 UTC (History)
2 users (show)

See Also:
gd: review+


Attachments
Patch to allow DNS lookups in winbind (4.49 KB, patch)
2012-09-20 11:33 UTC, Sumit Bose
asn: review+
Details
Fixed version of that patch (that is in master) (6.81 KB, patch)
2012-10-01 10:27 UTC, Guenther Deschner
asn: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Bose 2012-09-20 11:32:47 UTC
If a samba DC and an AD DC are in a different subnet, have a trust relationship and NetBIOS name resolution is not available winbindd cannot resolve any DC in the trusted domain, even if the DNS domain name of the trusted domain is available.

The attached patch tries to get the DNS domain name of the trusted domain and if it is available DNS lookups are used to resolve the DCs of the trusted domain. If it is not available a fallback to the original NetBIOS name resolution is done.
Comment 1 Sumit Bose 2012-09-20 11:33:45 UTC
Created attachment 7911 [details]
Patch to allow DNS lookups in winbind
Comment 2 Andreas Schneider 2012-09-21 07:32:12 UTC
Comment on attachment 7911 [details]
Patch to allow DNS lookups in winbind

Look good to me. Thanks for the patch.
Comment 3 Guenther Deschner 2012-10-01 10:25:22 UTC
*** Bug 9230 has been marked as a duplicate of this bug. ***
Comment 4 Guenther Deschner 2012-10-01 10:27:03 UTC
Created attachment 7970 [details]
Fixed version of that patch (that is in master)
Comment 5 Andreas Schneider 2012-10-01 10:30:00 UTC
Comment on attachment 7970 [details]
Fixed version of that patch (that is in master)

Looks good, thanks Günther!
Comment 6 Guenther Deschner 2012-10-01 10:34:42 UTC
Karolin, please add to rc2.
Comment 7 Jeremy Allison 2012-10-01 16:11:41 UTC
Do we need this in 3.6.x too ?

Jeremy.
Comment 8 Karolin Seeger 2012-10-02 06:50:48 UTC
Pushed to autobuild-v4-0-test.
Re-assigning to Günther to clarify if it's needed in v3-6-test also.

Thanks!
Comment 9 Björn Jacke 2014-09-17 13:15:02 UTC
3.6 won't get such fixes any more. Too late now to reply, Günther ;-)

I'll close the bug now.