Bug 9163 - Compile of v4 RC1 fails
Compile of v4 RC1 fails
Status: RESOLVED DUPLICATE of bug 9337
Product: Samba 4.0
Classification: Unclassified
Component: Build
4.0.0rc4
x86 Linux
: P5 major
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 14:15 UTC by Philippe Laurent
Modified: 2012-12-31 07:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Laurent 2012-09-14 14:15:08 UTC
Centos 6.3, patched as of yesterday.

Beta 8 was compiled and run successfully on the same machine yesterday, and I was able to fully configure and join a domain.

With today's RC1 release, I downloaded the tarball source, configure.developer/make, but make failed (really, it just hangs forever) after:

[1717/3777] Compiling librpc/ndr/ndr_basic.c

I've re-downloaded the tarball and started from scratch with the same results.

I was asked to run 'make V=1' and 'make V=2', and attach the files referenced in that command.

[root@smbad samba-4.0.0rc1]# make V=1
WAF_MAKE=1 ./buildtools/bin/waf build
Waf: Entering directory `/root/samba-4.0.0rc1/bin'
	Selected embedded Heimdal build
[ 125/3777] Generating VERSION
[ 160/3777] Generating smbd/build_options.c
[1717/3777] Compiling librpc/ndr/ndr_basic.c
09:57:38 runner /usr/bin/gcc -fPIC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DSTATIC_ndr_MODULES=NULL -DSTATIC_ndr_MODULES_PROTO -MD -Idefault/librpc -I../librpc -Idefault/include/public -I../include/public -Idefault/source4 -I../source4 -Idefault/lib -I../lib -Idefault/source4/lib -I../source4/lib -Idefault/source4/include -I../source4/include -Idefault/include -I../include -Idefault/lib/replace -I../lib/replace -Idefault -I.. -Idefault/libcli/util -I../libcli/util -Idefault/lib/talloc -I../lib/talloc -Idefault/lib/util/charset -I../lib/util/charset -Idefault/dynconfig -I../dynconfig -Idefault/lib/crypto -I../lib/crypto -I/ -I/usr/local/include -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H=1 -D_GNU_SOURCE=1 -D_XOPEN_SOURCE_EXTENDED=1 ../librpc/ndr/ndr_basic.c -c -o default/librpc/ndr/ndr_basic_156.o

[root@smbad samba-4.0.0rc1]# make V=2
WAF_MAKE=1 ./buildtools/bin/waf build
Waf: Entering directory `/root/samba-4.0.0rc1/bin'
	Selected embedded Heimdal build
[ 125/3777] Generating VERSION
[ 160/3777] Generating smbd/build_options.c
[1717/3777] Compiling librpc/ndr/ndr_basic.c
09:58:33 runner /usr/bin/gcc -fPIC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DSTATIC_ndr_MODULES=NULL -DSTATIC_ndr_MODULES_PROTO -MD -Idefault/librpc -I../librpc -Idefault/include/public -I../include/public -Idefault/source4 -I../source4 -Idefault/lib -I../lib -Idefault/source4/lib -I../source4/lib -Idefault/source4/include -I../source4/include -Idefault/include -I../include -Idefault/lib/replace -I../lib/replace -Idefault -I.. -Idefault/libcli/util -I../libcli/util -Idefault/lib/talloc -I../lib/talloc -Idefault/lib/util/charset -I../lib/util/charset -Idefault/dynconfig -I../dynconfig -Idefault/lib/crypto -I../lib/crypto -I/ -I/usr/local/include -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H=1 -D_GNU_SOURCE=1 -D_XOPEN_SOURCE_EXTENDED=1 ../librpc/ndr/ndr_basic.c -c -o default/librpc/ndr/ndr_basic_156.o

Attached is the gcc file.
Comment 1 Tadeu Cruz 2012-10-04 22:34:59 UTC
Samba4 RC2 continues with the problem.

CentOS 6.3 

[root@samba4 samba-4.0.0rc2]# make V=1
WAF_MAKE=1 ./buildtools/bin/waf build
Waf: Entering directory `/root/samba-4.0.0rc2/bin'
	Selected embedded Heimdal build
[ 130/3947] Generating VERSION
[ 165/3947] Generating smbd/build_options.c
[1804/3947] Compiling librpc/ndr/ndr_basic.c
19:32:29 runner /usr/bin/gcc -DDEVELOPER -DDEBUG_PASSWORD -fPIC -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -Wall -g -Wshadow -Werror=strict-prototypes -Wstrict-prototypes -Werror=pointer-arith -Wpointer-arith -Wcast-align -Werror=write-strings -Wwrite-strings -Werror-implicit-function-declaration -Wformat=2 -Wno-format-y2k -Wmissing-prototypes -fno-common -Werror=address -Wcast-qual -Werror=format -DSTATIC_ndr_MODULES=NULL -DSTATIC_ndr_MODULES_PROTO -MD -Idefault/librpc -I../librpc -Idefault/include/public -I../include/public -Idefault/source4 -I../source4 -Idefault/lib -I../lib -Idefault/source4/lib -I../source4/lib -Idefault/source4/include -I../source4/include -Idefault/include -I../include -Idefault/lib/replace -I../lib/replace -Idefault -I.. -Idefault/lib/socket_wrapper -I../lib/socket_wrapper -Idefault/lib/talloc -I../lib/talloc -Idefault/lib/util/charset -I../lib/util/charset -Idefault/lib/crypto -I../lib/crypto -Idefault/libcli/util -I../libcli/util -Idefault/lib/nss_wrapper -I../lib/nss_wrapper -Idefault/lib/uid_wrapper -I../lib/uid_wrapper -Idefault/dynconfig -I../dynconfig -I/ -I/usr/local/include -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H=1 -D_GNU_SOURCE=1 -D_XOPEN_SOURCE_EXTENDED=1 ../librpc/ndr/ndr_basic.c -c -o default/librpc/ndr/ndr_basic_156.o


----------------

[root@samba4 samba-4.0.0rc2]# make V=2
WAF_MAKE=1 ./buildtools/bin/waf build
Waf: Entering directory `/root/samba-4.0.0rc2/bin'
	Selected embedded Heimdal build
[ 130/3947] Generating VERSION
[ 165/3947] Generating smbd/build_options.c
[1804/3947] Compiling librpc/ndr/ndr_basic.c
19:32:56 runner /usr/bin/gcc -DDEVELOPER -DDEBUG_PASSWORD -fPIC -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -Wall -g -Wshadow -Werror=strict-prototypes -Wstrict-prototypes -Werror=pointer-arith -Wpointer-arith -Wcast-align -Werror=write-strings -Wwrite-strings -Werror-implicit-function-declaration -Wformat=2 -Wno-format-y2k -Wmissing-prototypes -fno-common -Werror=address -Wcast-qual -Werror=format -DSTATIC_ndr_MODULES=NULL -DSTATIC_ndr_MODULES_PROTO -MD -Idefault/librpc -I../librpc -Idefault/include/public -I../include/public -Idefault/source4 -I../source4 -Idefault/lib -I../lib -Idefault/source4/lib -I../source4/lib -Idefault/source4/include -I../source4/include -Idefault/include -I../include -Idefault/lib/replace -I../lib/replace -Idefault -I.. -Idefault/lib/socket_wrapper -I../lib/socket_wrapper -Idefault/lib/talloc -I../lib/talloc -Idefault/lib/util/charset -I../lib/util/charset -Idefault/lib/crypto -I../lib/crypto -Idefault/libcli/util -I../libcli/util -Idefault/lib/nss_wrapper -I../lib/nss_wrapper -Idefault/lib/uid_wrapper -I../lib/uid_wrapper -Idefault/dynconfig -I../dynconfig -I/ -I/usr/local/include -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H=1 -D_GNU_SOURCE=1 -D_XOPEN_SOURCE_EXTENDED=1 ../librpc/ndr/ndr_basic.c -c -o default/librpc/ndr/ndr_basic_156.o
Comment 2 Philippe Laurent 2012-10-16 19:23:07 UTC
Samba RC3 resolves the issue.

Same configuration as the original machine, no software changes. Compile produces successful binaries, and runs as expected.
Comment 3 Philippe Laurent 2012-10-30 17:33:15 UTC
The bug has re-appeared in RC4, exactly as previously described.
Comment 4 Andrew Bartlett 2012-12-31 07:37:39 UTC
This is fixed in offic

*** This bug has been marked as a duplicate of bug 9337 ***