Bug 8644 - vfs_acl_xattr and vfs_acl_tdb modules can fail to add inheritable entries on a directory with no stored ACL.
vfs_acl_xattr and vfs_acl_tdb modules can fail to add inheritable entries on ...
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: VFS Modules
3.6.1
All All
: P5 regression
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks: 8595
  Show dependency treegraph
 
Reported: 2011-12-02 18:45 UTC by Jeremy Allison
Modified: 2012-06-07 08:05 UTC (History)
3 users (show)

See Also:
rsharpe: review+
rsharpe: review+


Attachments
git-am fix for 3.6.x and 3.5.x. (1022 bytes, patch)
2011-12-02 22:13 UTC, Jeremy Allison
metze: review+
jra: review? (rsharpe)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2011-12-02 18:45:19 UTC
Found at an OEM.

Ensure Samba is running with acl_xattr loaded.

Using a Windows XP client with personal file sharing enabled (don't ask me why this needs to be so, it just does) - create a directory structure using notepad.exe as the following:

\source\t1.txt

\target

Where \source and \target are directories.

Then using explorer, "CUT" and paste (doesn't happen with COPY and paste) the \source directory into the \target directory. The operation will succeed, but whe accessing t1.txt by double clicking you will get "ACCESS DENIED".

This is due to an ACL with zero ACE entries being applied to t1.txt.

Patch to follow.
Comment 1 Jeremy Allison 2011-12-02 18:46:04 UTC
Note for the above. \source and \target need to be created from the Samba server, not by the client.
Comment 2 Jeremy Allison 2011-12-02 22:13:50 UTC
Created attachment 7155 [details]
git-am fix for 3.6.x and 3.5.x.

Fix I've applied to master (and confirms fixes the problem by the OEM).

Applies to 3.6.x and 3.5.x. It's a pretty obvious fix once you look at it.

Jeremy.
Comment 3 Jeremy Allison 2011-12-14 20:23:24 UTC
Ping. This really needs reviewing and adding to 3.6.next.

It's also correct :-).

Raising to blocker as I don't want to ship without this.

Jeremy.
Comment 4 Karolin Seeger 2011-12-27 18:58:47 UTC
Is there a chance to get the review done during the next two days?
Otherwise, we do need to delay 3.6.2 (which might happen anyway).

Thanks!
Comment 5 Richard Sharpe 2011-12-30 20:43:58 UTC
(In reply to comment #4)
> Is there a chance to get the review done during the next two days?
> Otherwise, we do need to delay 3.6.2 (which might happen anyway).
> 
> Thanks!

What do you want by way of review?

I have reviewed the code and the patch seems absolutely correct. 

However, I seem to be unable to mark it as reviewed.
Comment 6 Jeremy Allison 2011-12-31 01:46:41 UTC
Added Richard in the hope he can +1 this (obviously correct) fix.

Jeremy.
Comment 7 Richard Sharpe 2011-12-31 04:41:37 UTC
I must be doing something wrong. I show two +1 reviews by me (realrichardsharpe) but it is not clear that it has shown elsewhere.
Comment 8 Stefan Metzmacher 2012-01-02 08:45:12 UTC
Comment on attachment 7155 [details]
git-am fix for 3.6.x and 3.5.x.

Looks good.

Richard, there're also review flags on the attachment
Comment 9 Stefan Metzmacher 2012-01-02 08:45:55 UTC
Karolin, please pick for the next releases.
Comment 10 Karolin Seeger 2012-01-04 20:11:29 UTC
Pushed to v3-6-test and v3-5-test.
Closing out bug report.

Thanks!