I noticed that the naming of VFS functions in the structure that defines them is inconsistent. Eg: .open_fn = vfswrap_open, .create_file = vfswrap_create_file, .close_fn = vfswrap_close, .vfs_read = vfswrap_read, .pread = vfswrap_pread, .write = vfswrap_write, .pwrite = vfswrap_pwrite, They should all probably be called <name>_fn, eg, create_file_fn, read_fn, pread_fn, write_fn, etc. This will break out of tree modules, but the change is pretty mechanical.
For 3.6.2, I would not do this. For the next 3.x release, sure. If I was you, I would just post a patch somewhere and push it to master after some review. For 3.7 or 4.0 we don't have the bugzilla process.
This was fixed in change # 422494a8e630e2ca89386344eaa5346388698a32