Bug 8357 - smb2 credit handling bug with async io
smb2 credit handling bug with async io
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: File services
3.6.0rc3
All All
: P5 major
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks: 8595
  Show dependency treegraph
 
Reported: 2011-08-07 16:53 UTC by Stefan Metzmacher
Modified: 2011-11-14 19:15 UTC (History)
4 users (show)

See Also:


Attachments
Patch for v3-6-test (2.22 KB, patch)
2011-08-08 06:52 UTC, Stefan Metzmacher
jra: review+
Details
Regression fix from metze for 3.6.2. (1.56 KB, patch)
2011-11-11 22:50 UTC, Jeremy Allison
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2011-08-07 16:53:22 UTC
If someone uses an async io in the filesystem backend,
we are not granting credits on write/read responses,
which slows down the clients.

Jeremy, I'm not sure if this is blocker for 3.6.0,
because both SMB2 and async io are not the defaults.

If someone needs this, the patch can be applied
on top of 3.6.0.

However if Karolin is fine with picking it for 3.6.0,
it would be nice to have.

metze
Comment 1 Stefan Metzmacher 2011-08-07 17:09:39 UTC
The patch is currently in autobuild
Comment 2 Stefan Metzmacher 2011-08-08 06:52:42 UTC
Created attachment 6758 [details]
Patch for v3-6-test
Comment 3 Jeremy Allison 2011-08-08 09:06:12 UTC
Comment on attachment 6758 [details]
Patch for v3-6-test

Great catch ! Thanks metze. This explains an unexpected slowdown with async io.

Jeremy.
Comment 4 Jeremy Allison 2011-08-08 09:07:35 UTC
Re-assigning to Karolin for inclusion in 3.6.1. I agree, it is not a blocker for 3.6.0, but it should be one of the first patches applied to 3.6.1 :-).

Cheers,

Jeremy.
Comment 5 Karolin Seeger 2011-08-09 11:19:39 UTC
Pushed to v3-6-test.
Will be included in 3.6.0.
Closing out bug report.

Thanks!
Comment 6 Jeremy Allison 2011-11-11 22:49:34 UTC
Reopened to add metze's regression fix ffbd1ed2797616226a7987efd4b4dd4275c8c9d0 from master.
Jeremy.
Comment 7 Jeremy Allison 2011-11-11 22:50:17 UTC
Created attachment 7094 [details]
Regression fix from metze for 3.6.2.
Comment 8 Stefan Metzmacher 2011-11-12 08:59:35 UTC
Comment on attachment 7094 [details]
Regression fix from metze for 3.6.2.

Looks good
Comment 9 Stefan Metzmacher 2011-11-12 09:00:05 UTC
Karolin, please pick for the next release
Comment 10 Karolin Seeger 2011-11-14 19:15:14 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!