Bug 8344 - the --without-sendfile-support option did not at work when building samba
the --without-sendfile-support option did not at work when building samba
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Build environment
3.5.4
Sparc Solaris
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 4722 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 08:07 UTC by jinyunshuai
Modified: 2013-09-02 14:50 UTC (History)
2 users (show)

See Also:


Attachments
patch for 3.5 and 3.6 (1.91 KB, patch)
2012-09-13 22:16 UTC, Björn Jacke
metze: review+
Details
Patch for v4-0-test (1.97 KB, patch)
2012-10-10 07:12 UTC, Stefan Metzmacher
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jinyunshuai 2011-08-03 08:07:42 UTC
When i packaged install package on my build machine
I have tested 4 condition:

1> add --without-sendfile-support option when building and do not have 
   libsendfile.so.1 on build machine. 
   test result: new install package does not dependent on libsendfile.so.1

2> add --without-sendfile-support option when building and have 
   libsendfile.so.1 on build machine .
   test result: new install package dependent on libsendfile.so.1

3> do not add --without-sendfile-support option when building and do not have 
   libsendfile.so.1 on build machine. 
   test result: new install package does not dependent on libsendfile.so.1

4> do not add --without-sendfile-support option when building and have 
   libsendfile.so.1 no build machine. 
   test result: new install package dependent on libsendfile.so.1


So the "--without-sendfile-support" option did not at work,whether build packege dependent on libsendfile.so.1, just related to are there  libsendfile.so.1 on build machine .
Comment 1 jinyunshuai 2011-08-03 08:19:08 UTC
After take a look  at configure file. 

in configure:80182

with_sendfile_support=yes
{ $as_echo "$as_me:$LINENO: checking whether to check to support sendfile" >&5
$as_echo_n "checking whether to check to support sendfile... " >&6; }

# Check whether --with-sendfile-support was given.
if test "${with_sendfile_support+set}" = set; then
  withval=$with_sendfile_support;  case "$withval" in
  yes)

From above code we can see that before check whether --with-sendfile-support
was given , with_sendfile_support is set to yes by 'with_sendfile_support=yes'

So  "--with-sendfile-support=no| --without-sendfile-support" option doesn't
take effect.
is this the root cause?
Comment 2 jinyunshuai 2011-08-03 08:25:24 UTC
I modify code from

================================================
with_sendfile_support=yes
{ $as_echo "$as_me:$LINENO: checking whether to check to support sendfile" >&5
$as_echo_n "checking whether to check to support sendfile... " >&6; }

# Check whether --with-sendfile-support was given.
if test "${with_sendfile_support+set}" = set; then
  withval=$with_sendfile_support;  case "$withval" in
  yes)
==================================================
to

======================================================
#with_sendfile_support=yes
{ $as_echo "$as_me:$LINENO: checking whether to check to support sendfile" >&5
$as_echo_n "checking whether to check to support sendfile... " >&6; }

# --with-sendfile-support default value is yes
if  test "${with_sendfile_support+set}" != set ; then
    with_sendfile_support=yes;                               
fi

# Check whether --with-sendfile-support was given.
if test "${with_sendfile_support+set}" = set; then
  withval=$with_sendfile_support;  case "$withval" in
  yes)
======================================================

I have test follows three conditions

1> use --with-sendfile-support default value 
   result: dependent on libsendfile.so.1

2> add with_sendfile_support=yes 
   result: dependent on libsendfile.so.1

3> add --without-sendfile-support 
   result: did not dependent on libsendfile.so.1

so the modification fix this bug!
Comment 3 jinyunshuai 2011-08-03 08:37:55 UTC
If this issue still in the current branch of v3-5-test?

If so, how can check in the change to v3-5-test branch, what the step to do ?  ^_^



Thinks
Kingson
Centrify Corp.
Comment 4 Björn Jacke 2012-09-13 22:16:08 UTC
Created attachment 7894 [details]
patch for 3.5 and 3.6

indeed, compiling in of sendfile support did not work. Attached git patch fixes that for 3.5 and 3.6.

The corresponding patch from master should be picked to 4.0.
Comment 5 Karolin Seeger 2012-09-17 10:02:53 UTC
Re-assigning to Metze for patch review.
Comment 6 Stefan Metzmacher 2012-10-10 07:09:36 UTC
Comment on attachment 7894 [details]
patch for 3.5 and 3.6

Looks ok
Comment 7 Stefan Metzmacher 2012-10-10 07:12:46 UTC
Created attachment 8037 [details]
Patch for v4-0-test

Looks good
Comment 8 Stefan Metzmacher 2012-10-10 07:13:29 UTC
Karolin, please pick for the next releases
Comment 9 Karolin Seeger 2012-10-10 08:50:47 UTC
Pushed to autobuild-v4-0-test, v3-6-test and v3-5-test.
Closing out bug report.

Thanks!
Comment 10 Björn Jacke 2013-09-02 14:50:15 UTC
*** Bug 4722 has been marked as a duplicate of this bug. ***