Bug 8148 - Default to protocol version 2 for SMB Traffic Analyzer in Samba 3.6.0
Default to protocol version 2 for SMB Traffic Analyzer in Samba 3.6.0
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: VFS Modules
3.6.0rc1
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-18 19:52 UTC by Holger Hetterich
Modified: 2011-05-20 19:20 UTC (History)
1 user (show)

See Also:
hhetter: review? (jra)


Attachments
Patch against master and 3.6.0 (4.05 KB, patch)
2011-05-18 19:52 UTC, Holger Hetterich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Hetterich 2011-05-18 19:52:01 UTC
Created attachment 6452 [details]
Patch against master and 3.6.0

At the time I developed the protocol version 2 of smb traffic analyzer, few people actually tried it. Therefore, I've set version 1 of the protocol to the default configuration.

I've got no user feedback or response for version 1 of the protocol since at least 1 1/2 years. Therefore I would like to make protocol 2 the default setting with Samba 3.6.0.

Protocol 2 is the one that is activly supported, actually has a userbase, and a group of developers around it.

The attached patch - as suggested on the technical mailinglist - makes version 2 of the protocol the default, and only runs on version 1 if it is specifically given as an option.

It contains a manpage update addressing the change.
Comment 1 Jeremy Allison 2011-05-18 23:52:46 UTC
Looks good to me for inclusion in 3.6.0.
Re-assigning to Karolin.

Jeremy.
Comment 2 Karolin Seeger 2011-05-20 19:20:21 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!