Bug 778 - libsmb/clikrb5.c fails on missing "eblock" definition
Summary: libsmb/clikrb5.c fails on missing "eblock" definition
Status: RESOLVED DUPLICATE of bug 777
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: libsmbclient (show other bugs)
Version: 3.0.0
Hardware: All OpenBSD
: P2 regression
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-13 20:17 UTC by Ed Vazquez
Modified: 2005-11-14 09:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Vazquez 2003-11-13 20:17:39 UTC
The intent:
Install Samba on OpenBSD to act as a "worm catcher".  Since the environment is
native-mode Windows 2000, this necessitates building the Active Directory modules.

The system:
OpenBSD 3.4 i386
gcc version 2.95.3 20010125 (prerelease, propolice)
GNU Make 3.80
autoconf (GNU Autoconf) 2.57
automake (GNU automake) 1.4-p6
libiconv 1.8
cvs checkout 14Nov2003 0248 UTC

The configure options (OpenBSD placement mostly):
./configure \
--prefix=/usr \
--sbindir=/usr/libexec \
--sysconfdir=/etc/samba \
--localstatedir=/var \
--libdir=/usr/lib/samba \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--disable-cups \
--with-privatedir=/etc/samba \
--with-lockdir=/var/spool/samba \
--with-piddir=/var/run \
--with-swatdir=/usr/share/swat \
--with-configdir=/etc/samba \
--with-ads \
--with-utmp \
LDFLAGS="-L/usr/local/lib" \
CPPFLAGS="-I/usr/local/include -I/usr/include/kerberosV"

The error:
Compiling libsmb/clikrb5.c
libsmb/clikrb5.c: In function `create_kerberos_key_from_string':
libsmb/clikrb5.c:92: syntax error before `eblock'
libsmb/clikrb5.c:99: `eblock' undeclared (first use in this function)
libsmb/clikrb5.c:99: (Each undeclared identifier is reported only once
libsmb/clikrb5.c:99: for each function it appears in.)
libsmb/clikrb5.c:100: warning: passing arg 3 of `krb5_string_to_key' from
incompatible pointer type
libsmb/clikrb5.c:100: warning: passing arg 4 of `krb5_string_to_key' from
incompatible pointer type
libsmb/clikrb5.c:100: warning: passing arg 5 of `krb5_string_to_key' from
incompatible pointer type
libsmb/clikrb5.c: In function `krb5_princ_component':
libsmb/clikrb5.c:405: warning: assignment discards qualifiers from pointer
target type
gmake: *** [libsmb/clikrb5.o] Error 1

The Diagnosis:
The "eblock" definition only exists in the MIT distribution of Kerberos (krb5.h).

To build successfully in OpenBSD with ADS, the Heimdal version must be
installed, which does not have the "eblock" setting defined.
Comment 1 Gerald (Jerry) Carter 2003-11-21 21:52:31 UTC

*** This bug has been marked as a duplicate of 777 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:28:52 UTC
database cleanup