Bug 7447 - Profile set to local when password changing if expired
Profile set to local when password changing if expired
Status: RESOLVED WONTFIX
Product: Samba 3.3
Classification: Unclassified
Component: User & Group Accounts
3.3.12
x64 Windows XP
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 05:02 UTC by Marc Muehlfeld
Modified: 2010-06-07 03:23 UTC (History)
0 users

See Also:


Attachments
Zipped level 10 debug log (767.64 KB, application/octet-stream)
2010-05-21 05:06 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2010-05-21 05:02:03 UTC
Hello,

I found a reproducable problem: If a password from a user is expired and he/she is forced to change it at the logon, the profile is not loaded from the server. Instead of this, a local profile is created and used. The problem is, that if a local profile is existing on a workstation, the serverbased isn't used any more.

Maximum PW age: 90 days
Minimum PW age: 14 days
Minimum PW lenght: At least 8 characters
Rember last 4 PW
Comment 1 Marc Muehlfeld 2010-05-21 05:06:27 UTC
Created attachment 5725 [details]
Zipped level 10 debug log

Level 10 debug log of password change at the windows logon (after "pw expired" was shown). The logon script runs fine. But the server based profile was not loaded and a local one was created.
Comment 2 Marc Muehlfeld 2010-06-07 03:23:05 UTC
It's not a problem of samba. It's a problem that MS introduced with XP SP3:
http://support.microsoft.com/?scid=kb%3Ben-us%3B958058&x=13&y=10

MS provides a hotfix that can be requested (not for public download).