Bug 7348 - Use of uninitialized value in string eq at ./../selftest/selftest.pl when running make quicktest
Use of uninitialized value in string eq at ./../selftest/selftest.pl when run...
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
x64 Linux
: P3 minor
: ---
Assigned To: Jelmer Vernooij
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-10 20:53 UTC by Jonn Taylor
Modified: 2010-04-18 13:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonn Taylor 2010-04-10 20:53:23 UTC
This does complete ok.


[root@bdc source4]# make quicktest
Samba will be compiled with flags:
  CPP        = gcc -E
  CPPFLAGS   = -I./include -I. -I./lib -I./../lib/replace -I./../lib/talloc -I./.. -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H 
  CC         = gcc
  CFLAGS     = -g -DDEBUG_PASSWORD -DDEVELOPER -Wall -Wshadow -Werror-implicit-function-declaration -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wmissing-format-attribute -Wformat=2 -Wdeclaration-after-statement -Wunused-macros -Wno-format-y2k -Wno-unused-parameter
  PICFLAG    = -fPIC
  BNLD       = gcc
  BNLD_FLAGS =  -Wl,--export-dynamic
  STLD       = /usr/bin/ar
  STLD_FLAGS = -rcs
  SHLD       = gcc
  SHLD_FLAGS = -shared -Wl,-Bsymbolic 
  MDLD       = gcc
  MDLD_FLAGS = -shared -Wl,-Bsymbolic -Wl,--allow-shlib-undefined
  SHLIBEXT   = so
  srcdir     = .
  builddir   = .
  pwd        = /usr/src/redhat/SOURCES/samba-master/source4
( rm -f ./st/st_done &&  LD_LIBRARY_PATH=./bin/shared:$LD_LIBRARY_PATH PYTHON=/usr/bin/python2.4 /usr/bin/perl -W ./../selftest/selftest.pl --prefix=./st --builddir=. --srcdir=. --exclude=./selftest/skip --testlist="./selftest/tests.sh|"  --exclude=./selftest/slow --quick --include=./selftest/quick --socket-wrapper  && touch ./st/st_done )  | /usr/bin/python2.4 -u ./../selftest/filter-subunit --expected-failures=./selftest/knownfail | /usr/bin/python2.4 -u ./../selftest/format-subunit --prefix=./st --immediate
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 3.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 7.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 11.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 15.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 19.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 23.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 27.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 31.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 35.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 39.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 43.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 47.
SOCKET_WRAPPER_DIR=/usr/src/redhat/SOURCES/samba-master/source4/st/w
Version 4.0.0alpha12-GIT-18078ec
OPTIONS  --configfile=$SMB_CONF_PATH --maximum-runtime=1200 --target=samba4 --basedir=/usr/src/redhat/SOURCES/samba-master/source4/st/s4client --option=torture:progress=no --format=subunit --option=torture:quick=yes
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 51.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 55.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 59.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 63.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 67.
Use of uninitialized value in string eq at ./../selftest/selftest.pl line 644, <IN> line 71.


.
.
.
.
ALL OK (1252 tests in 195 testsuites)
[root@bdc source4]#
Comment 1 Matthias Dieter Wallnöfer 2010-04-17 13:54:33 UTC
I suppose you are using an older perl release from around 2005. I tried s4 myself once with such version (on CentOS 4) and got the same warnings.
The tests do pass ("ALL OK (1252 tests in 195 testsuites)") so just ignore them.

I mark this as "INVALID". If you find a serious error caused by the old perl environment I suggest you to reopen this report.

Btw: we are more and more moving away to Python for this kind of scripts - so probably this could disappear soon.
Comment 2 Jonn Taylor 2010-04-18 13:30:54 UTC
This is on CentOS 5.4. Current git pull resolved the errors.