Bug 7261 - /var/run/samba/ntp_signd and /var/run/samba/winbindd are not created automatically
/var/run/samba/ntp_signd and /var/run/samba/winbindd are not created automati...
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
x86 Other
: P3 minor
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 06:38 UTC by sassy.natan
Modified: 2012-02-24 15:33 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sassy.natan 2010-03-18 06:38:45 UTC
/var/run/samba/ntp_signd and /var/run/samba/winbindd are not created automatically when running samba4. 
After Creating them manually Samba4 runs OK.
Comment 1 Matthias Dieter Wallnöfer 2010-03-30 08:12:06 UTC
Do you run s4 at least once with the "root" account? Since only then we have the permission to create these two folders and the sockets in it. Another problem could be that the path specified on "configure" and the installation path afterwards don't match. Then please perform a full rebuild ("make clean", "configure", "make"...)

I mark this as "INVALID" since this isn't a bug (tested on my computer).
Comment 2 sassy.natan 2010-04-11 10:37:49 UTC
(In reply to comment #1)
> Do you run s4 at least once with the "root" account? Since only then we have
> the permission to create these two folders and the sockets in it. Another
> problem could be that the path specified on "configure" and the installation
> path afterwards don't match. Then please perform a full rebuild ("make clean",
> "configure", "make"...)
> 
> I mark this as "INVALID" since this isn't a bug (tested on my computer).
> 

Comment 3 sassy.natan 2010-04-11 10:39:27 UTC
Even when running first time with root, the dirs are not created

I used Debian Lenny. With a pre-packed deb pkg using jelmer work, of the latest git from today 11/04/2010

Sassy




Comment 4 Jelmer Vernooij 2010-04-11 10:42:58 UTC
Matthias, /var/run can exist (In reply to comment #1)
> Do you run s4 at least once with the "root" account? Since only then we have
> the permission to create these two folders and the sockets in it. Another
> problem could be that the path specified on "configure" and the installation
> path afterwards don't match. Then please perform a full rebuild ("make clean",
> "configure", "make"...)
> 
> I mark this as "INVALID" since this isn't a bug (tested on my computer).
just because you can't reproduce it doesn't mean it's not a bug... 

/var/run can be on a tmpfs, in which case these directories disappear after each reboot.

Arguably creating these directories could also be done in the init script on D
Comment 5 Jelmer Vernooij 2010-04-11 10:44:12 UTC
Arguably these directories could also be created by the init script, but since they are configurable in smb.conf that is a bit tricky. It would be much simpler if samba could take care of creating them.
Comment 6 Matthias Dieter Wallnöfer 2010-04-11 14:28:03 UTC
Natan, sorry I closed the bug due to a misconception. You speak from the "PID" files under "var/run" I however controlled the socket files and directories under "var/lib" (and these work).

I will talk to someone about fixing this (I think the bug shows up only on FHS installations and therefore was undiscovered 'till now).
Comment 7 Matthias Dieter Wallnöfer 2010-04-15 12:02:14 UTC
This could have been fixed by http://gitweb.samba.org/samba.git/?p=samba.git;a=commitdiff;h=7233699ad849b0771c946eb47b31ff50f64cefbf. Please rebuild using WAF and retest!
Comment 8 Stefan Metzmacher 2010-04-15 12:21:07 UTC
No, I still need to do a mkdir -p /var/run/samba
Comment 9 Matthieu Patou 2010-10-30 05:40:59 UTC
isnt' it a pb of the init script ? 
Comment 10 Jelmer Vernooij 2012-02-24 15:33:00 UTC
Arguably this should be done by the init script, and this is what happens on Debian/Ubuntu these days.