Bug 7228 - Can't access files via shortname
Can't access files via shortname
Status: RESOLVED WORKSFORME
Product: Samba 3.4
Classification: Unclassified
Component: File services
3.4.3
x86 Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-09 09:47 UTC by Jörg Sommer
Modified: 2010-10-25 10:37 UTC (History)
0 users

See Also:


Attachments
Dump of network traffic while reproducing the problem (12.91 KB, application/octet-stream)
2010-03-09 09:52 UTC, Jörg Sommer
no flags Details
Log of samba while reproducing this bug (291.32 KB, text/plain)
2010-03-09 09:53 UTC, Jörg Sommer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Sommer 2010-03-09 09:47:50 UTC
Hi,

I can't access a file via shortname from Windows XP

P:\>dir /X
 Datenträger in Laufwerk P: ist suomi
 Volumeseriennummer: 0854-04DD

 Verzeichnis von P:\

03.03.2010  10:23    <DIR>                       .
19.08.2009  14:10    <DIR>                       ..
09.03.2010  16:16                13 N12E97~C.TXT name.with.dots.txt
03.03.2010  10:23                 6              owner
20.04.2009  10:25    <DIR>          PJQWT0~M     public_html
               2 Datei(en)             19 Bytes
               3 Verzeichnis(se), 86.176.780.288 Bytes frei

P:\>more name.with.dots.txt
hello world

P:\>more N12E97~C.TXT
Auf die Datei P:\N12E97~C.TXT kann nicht zugegriffen werden.
Comment 1 Jörg Sommer 2010-03-09 09:52:41 UTC
Created attachment 5476 [details]
Dump of network traffic while reproducing the problem
Comment 2 Jörg Sommer 2010-03-09 09:53:53 UTC
Created attachment 5477 [details]
Log of samba while reproducing this bug
Comment 3 Jeremy Allison 2010-03-10 14:58:19 UTC
I can't reproduce this with 3.5.1, so it looks like something we've fixed. Can you upgrade please ?

Jeremy.
Comment 4 Volker Lendecke 2010-10-25 10:37:57 UTC
Works fine here also with both master and 3.4.3. We need more information on this bug: Please post your smb.conf and the full debug level 10 log, also containing the listing. In the one you posted I only see the calls to "more", not the "dir/x".

Closing as WORKSFORME, please re-open when the information is available.

Volker