Bug 673 - Standalone server crashes on missing PDC
Standalone server crashes on missing PDC
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.0preX
All Linux
: P3 major
: 3.0.1
Assigned To: Gerald (Jerry) Carter
http://www.esmt.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 03:22 UTC by Thomas Werner
Modified: 2007-05-12 09:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Werner 2003-10-23 03:22:13 UTC
we on the european school in munich use 3 samba3 server:

- pdc (ldap master)
- bdc (ldap slave)
- standalone server (fileserver)

everthing works perfect, any client can logon the pdc or bdc and get the profile
data from the fileserver. but if the pdc is down, any client connect to the bdc
and try to logon and it works, but the fileserver crashes with the message 'PDC
not reachable'. i tried an configuration with no success and i think with a
mistake in the configuration, the server should not be crashing. i tested it
since samba3.0.0rc3.

cheers tom@esmt.org


##################
# FILESERVER LOG #
################## 

[2003/09/21 19:35:32, 1] smbd/service.c:make_connection_snum(696)
  esmt-00039 (192.168.52.239) connect to service profile$ initially as user root
(uid=0, gid=0) (pid 7626)
[2003/09/21 19:36:31, 1] smbd/service.c:close_cnum(878)
  esmt-00039 (192.168.52.239) closed connection to service profile$
[2003/09/21 19:37:01, 1] smbd/service.c:close_cnum(878)
  esmt-00039 (192.168.52.239) closed connection to service profile$
[2003/09/21 19:38:25, 1] libsmb/cliconnect.c:cli_connect(1222)
  Error connecting to 192.168.52.33 (Connection refused)
[2003/09/21 19:38:25, 1] libsmb/cliconnect.c:cli_start_connection(1302)
  cli_full_connection: failed to connect to PDC<20> (192.168.52.33)
[2003/09/21 19:38:25, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/09/21 19:38:25, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 7627 (3.0.0rc4)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/09/21 19:38:25, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/09/21 19:38:25, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2003/09/21 19:38:25, 0] lib/util.c:smb_panic(1407)
  BACKTRACE: 21 stack frames:
   #0 /usr/local/samba/sbin/smbd(smb_panic+0xfd) [0x8198d6d]
   #1 /usr/local/samba/sbin/smbd [0x818851a]
   #2 /lib/libc.so.6 [0x40220d68]
   #3 /usr/local/samba/sbin/smbd(enumerate_domain_trusts+0x106) [0x81d1c86]
   #4 /usr/local/samba/sbin/smbd(update_trustdom_cache+0xc7) [0x81d17f7]
   #5 /usr/local/samba/sbin/smbd(is_trusted_domain+0x6d) [0x81cd61d]
   #6 /usr/local/samba/sbin/smbd(make_user_info_map+0x89) [0x81caef9]
   #7 /usr/local/samba/sbin/smbd [0x81cd9e4]
   #8 /usr/local/samba/sbin/smbd [0x80e7054]
   #9 /usr/local/samba/sbin/smbd(ntlmssp_server_update+0xfc) [0x80e73bc]
   #10 /usr/local/samba/sbin/smbd(auth_ntlmssp_update+0x2a) [0x81cdc3a]
   #11 /usr/local/samba/sbin/smbd [0x80a2c1d]
   #12 /usr/local/samba/sbin/smbd [0x80a2e33]
   #13 /usr/local/samba/sbin/smbd(reply_sesssetup_and_X+0xb17) [0x80a3ab7]
   #14 /usr/local/samba/sbin/smbd [0x80be0d1]
   #15 /usr/local/samba/sbin/smbd [0x80be24a]
   #16 /usr/local/samba/sbin/smbd(process_smb+0x83) [0x80be463]
   #17 /usr/local/samba/sbin/smbd(smbd_process+0x159) [0x80befc9]
   #18 /usr/local/samba/sbin/smbd(main+0x423) [0x81f5fa3]
   #19 /lib/libc.so.6(__libc_start_main+0xa2) [0x4020f4a2]
   #20 /usr/local/samba/sbin/smbd(ldap_msgfree+0x69) [0x8076591]
[2003/09/21 19:38:25, 1] libsmb/cliconnect.c:cli_connect(1222)
  Error connecting to 192.168.52.33 (Connection refused)
[2003/09/21 19:38:25, 1] libsmb/cliconnect.c:cli_start_connection(1302)
  cli_full_connection: failed to connect to PDC<20> (192.168.52.33)
[2003/09/21 19:38:25, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/09/21 19:38:25, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 7628 (3.0.0rc4)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/09/21 19:38:25, 0] lib/fault.c:fault_report(39)
  ===============================================================

################
# PDC SMB.CONF #
################ 

[global]

	; basic server settings
	netbios name = PDC
	server string = ESMT Primary Domain Controller
	workgroup = ESMT-MUNICH

	; user and machine account backends
	passdb backend = ldapsam:ldap://192.168.52.31, guest

	; should act as the domain and local master browser
	os level = 64
	preferred master = yes
	domain master = yes
	local master = yes

	; security settings
	security = user

	; necessary for domain controller
	encrypt passwords = yes

	; support domain logons
	domain logons = yes

	; user's home and profile directory
	logon drive = H:
	logon home = \\FILESERVER\%u\.profiles
	logon path = \\FILESERVER\profile$\%U

	; ldap related stuff
	ldap suffix = o=munich,dc=esmt,dc=org
	ldap admin dn = cn=manager,ou=samba,o=munich,dc=esmt,dc=org
	ldap filter = "(&(uid=%u)(objectClass=sambaSamAccount))"
	ldap ssl = start tls
	#ldap ssl = yes
	#ldap ssl = no
	ldap delete dn = no
	ldap user suffix = ou=users
	ldap machine suffix = ou=samba
	; ldap trust ids = yes

	; sync samba with unix password
	; unix password sync = yes
	; passwd program = /usr/local/sbin/ldapsync.pl -o %u
	; passwd chat = *New*password* %n\n *Retype*new*password* %n\n *modifying* 
	; passwd chat debug = yes
	ldap passwd sync = yes

	idmap backend = ldap:ldap://192.168.52.31
	ldap idmap suffix = ou=samba,o=munich,dc=esmt,dc=org
	idmap uid = 10000-20000
	idmap gid = 10000-20000

	; wins server
	wins support = yes

	; using interface protection
	interfaces = eth0 lo
	bind interfaces only = yes

	; only samba 2.x
	; domain admin group = " @"Domain Admins" "

	; time sync
	; time offset = 60 
	; time server = True 

; using a ipc share deny
[ipc$]

	hosts allow = 192.168.52.0/24 127.0.0.1
	hosts deny = 0.0.0.0/0
	path = /var/tmp

; necessary share for domain controller
[netlogon]

	path = /usr/local/samba/lib/netlogon
	guest ok = yes
	read only = yes
	write list = ntadmin
	browseable = no

################
# BDC SMB.CONF #
################ 

[global]

	; basic server settings
	netbios name = BDC
	server string = ESMT Backup Domain Controller
	workgroup = ESMT-MUNICH

	; user and machine account backends
	passdb backend = ldapsam:ldap://192.168.52.32, guest

	; should act as the domain and local master browser
	os level = 54
	domain master = no

	; security settings
	security = user

	; necessary for domain controller
	encrypt passwords = yes

	; support domain logons
	domain logons = yes

	; user's home and profile directory
	logon drive = H:
	logon home = \\FILESERVER\%u\.profiles
	logon path = \\FILESERVER\profile$\%U

	; ldap related stuff
	ldap suffix = o=munich,dc=esmt,dc=org
	ldap admin dn = cn=manager,ou=samba,o=munich,dc=esmt,dc=org
	ldap filter = "(&(uid=%u)(objectClass=sambaSamAccount))"
	ldap ssl = start tls
	ldap delete dn = no
	ldap user suffix = ou=users
	ldap machine suffix = ou=samba
	; ldap trust ids = yes

	; sync samba with unix password
	; unix password sync = yes
	; passwd program = /usr/local/sbin/ldapsync.pl -o %u
	; passwd chat = *New*password* %n\n *Retype*new*password* %n\n *modifying* 
	; passwd chat debug = yes
	ldap passwd sync = yes

	idmap backend = ldap:ldap://192.168.52.32
	ldap idmap suffix = ou=samba,o=munich,dc=esmt,dc=org
	idmap uid = 10000-20000
	idmap gid = 10000-20000

	; wins server
	wins support = yes

	; using interface protection
	interfaces = eth0 lo
	bind interfaces only = yes

	; only samba 2.x
	; domain admin group = " @"Domain Admins" "

; using a ipc share deny
[ipc$]

	hosts allow = 192.168.52.0/24 127.0.0.1
	hosts deny = 0.0.0.0/0
	path = /var/tmp

; necessary share for domain controller
[netlogon]

	path = /usr/local/samba/lib/netlogon
	guest ok = yes
	read only = yes
	write list = ntadmin
	browseable = no


#######################
# FILESERVER SMB.CONF #
####################### 

[global]

	; basic server settings
	netbios name = FILESERVER
	server string = ESMT File Server
	workgroup = ESMT-MUNICH

	; user and machine account backends
	; passdb backend = ldapsam:ldap://192.168.52.31, guest
	password server = PDC, BDC

	; should act as the domain and local master browser
	os level = 53
	; domain master = no

	; security settings
	security = domain

	; necessary for domain controller
	encrypt passwords = yes

	; support domain logons
	; domain logons = yes

	; ldap related stuff
	; ldap suffix = o=munich,dc=esmt,dc=org
	; ldap admin dn = cn=manager,ou=samba,o=munich,dc=esmt,dc=org
	; ldap filter = "(&(uid=%u)(objectClass=sambaSamAccount))"
	; ldap ssl = start ssl
	; ; ldap ssl = no
	; ldap delete dn = no
	; ldap user suffix = ou=users
	; ldap machine suffix = ou=samba
	; ; ldap trust ids = yes

	; idmap backend = ldap:ldap://192.168.52.31
	; ldap idmap suffix = ou=samba,o=munich,dc=esmt,dc=org
	; idmap uid = 10000-20000
	; idmap gid = 10000-20000

	; wins server
	wins support = no
	wins proxy = no
	wins server = 192.168.52.33 192.168.52.34

	; using interface protection
	interfaces = eth0 lo
	bind interfaces only = yes

; using a ipc share deny
[ipc$]

	hosts allow = 192.168.52.0/24 127.0.0.1
	hosts deny = 0.0.0.0/A
	path = /var/tmp

; share for storing user profises
[profile$]

        comment = Profile Data
	path = /mnt/nfs/profile
        read only = no
        create mask = 0600
        directory mask = 0700
	profile acls = yes 

; share for global system data
[system$]

        comment = Global System Data
        path = /mnt/nfs/system
        read only = yes

; home directories
[home]
        comment = Home Directories
        path = /mnt/nfs/home/%u
        browseable = no
        read only = no
        create mode = 0750

; share all printers
[printers]
	comment = All Printers
	path = /var/spool/samba
	browseable = no
	# Set public = yes to allow user 'guest account' to print
	guest ok = no
	writable = no
	printable = yes
	create mode = 0700

; share printer driver
[print$]
	comment = Printer Driver Download Area
	path = /mnt/nfs/drivers
	browseable = yes
	guest ok = yes
	read only = yes
	write list = @ntadmin, root

; necessary share for domain controller
[netlogon]

	path = /usr/local/samba/lib/netlogon
	guest ok = yes
	read only = yes
	write list = ntadmin
	browseable = no
Comment 1 Gerald (Jerry) Carter 2003-11-21 21:14:03 UTC
I see where this is bombing out, but I can't reproduce it.
It appears that this has been fixed.  Please reopen this
bug if you can still reproduce it against the latest SAMBA_3_0
cvs tree (or even 3.0.1pre3).
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:06:28 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:20:14 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:31:31 UTC
database cleanup
Comment 5 SPAMMER 2007-05-12 09:35:25 UTC
Created attachment 2690