Bug 6615 - Unable to access DFS share when using kerberos in smbclient
Unable to access DFS share when using kerberos in smbclient
Status: CLOSED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: libsmbclient
3.4.0
All Linux
: P3 normal
: ---
Assigned To: boyang
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-06 10:13 UTC by boyang
Modified: 2009-08-11 05:07 UTC (History)
2 users (show)

See Also:


Attachments
patch for 3.3 (1.11 KB, patch)
2009-08-06 10:14 UTC, boyang
derrell.lipman: review+
Details
patch for 3.4 (1.35 KB, patch)
2009-08-06 10:14 UTC, boyang
derrell.lipman: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description boyang 2009-08-06 10:13:15 UTC
Because smbc_set_credential_with_fallback() won't allow empty username, password, when using kerberos auth to browse DFS shares, use_kerberos won't be set to contact the target server, which results in inability to access target shares.

affect both 3.3 and 3.4.

thx!
Comment 1 boyang 2009-08-06 10:14:24 UTC
Created attachment 4520 [details]
patch for 3.3
Comment 2 boyang 2009-08-06 10:14:53 UTC
Created attachment 4521 [details]
patch for 3.4
Comment 3 Volker Lendecke 2009-08-06 10:20:38 UTC
Please provide exact steps to reproduce this bug.

Thanks,

Volker
Comment 4 boyang 2009-08-07 01:32:48 UTC
Join a linux machine into windows domain, enable kerberos login in pam_winbind, login user and try to access DFS share with nautilus or konqueror, click on DFS link, cannot access it.

Of course the user have rights to access the DFS target directly.

OR use the small test I submitted to master. After login to the machine/get the kerberos ticket, run stat_k smb://servername/DFSroot/DFSlink_name will fail. run it on normal share succeeds.

Be aware that master is already patched, so this will happen to v3.3 and v3.4.

Comment 5 Derrell Lipman 2009-08-07 09:26:39 UTC
Comment on attachment 4520 [details]
patch for 3.3

The patch look fine. I don't have the environment set up to be able to test it, so I'll have to depend on others for that at the moment.
Comment 6 Derrell Lipman 2009-08-07 09:27:01 UTC
Comment on attachment 4521 [details]
patch for 3.4

The patch look fine. I don't have the environment set up to be able to test it, so I'll have to depend on others for that at the moment.
Comment 7 boyang 2009-08-09 20:19:17 UTC
@Karolin:
   Please add this into 3.3 and 3.4. Thanks!
   Sorry that I didn't find a way to reassign the bug to you, looks like I have no such rights.
Comment 8 Karolin Seeger 2009-08-11 04:52:23 UTC
Pushed to v3-4-test and v3-3-test.
Patch does not seem to be in master.
Re-assigning bug to Bo.
Comment 9 boyang 2009-08-11 05:07:20 UTC
It is there. :-)

commit 857140a7.

Thanks!

close it now..