Bug 6286 - idmap_ldap + idmap_tdb are no longer statically built in by default
idmap_ldap + idmap_tdb are no longer statically built in by default
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: Winbind
3.3.3
Other Linux
: P3 regression
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 6141 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 02:49 UTC by Guenther Deschner
Modified: 2009-05-03 02:21 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2009-04-23 02:49:21 UTC
idmap_ldap + idmap_tdb are no longer statically built in by default

reproduce:

start winbind with minimal idmap configuration (idmap uid and idmap gid), call wbinfo --allocate-uid, --allocate-gid.
Comment 1 Guenther Deschner 2009-04-24 03:13:27 UTC
It turns out that the initialization function for the builtin-by-default backends was not called at the right time.

http://gitweb.samba.org/?p=samba.git;a=commitdiff;h=a552aa1c3f67b76692e26a5560640dcfae0831b6

fixes it for me.
Comment 2 Guenther Deschner 2009-04-24 09:14:21 UTC
Ok, I'm not closing this myself without having someone having put up testresults in here. This is critical :)
Comment 3 Karolin Seeger 2009-04-27 02:37:05 UTC
After applying the patch, wbinfo --allocate-uid and --allocate-gid both work for me.
Comment 4 Karolin Seeger 2009-05-03 01:41:16 UTC
I think this one is fixed in Samba 3.3.4.
Please re-open if it's still an issue.
Closing out bug report.
Comment 5 Karolin Seeger 2009-05-03 02:21:13 UTC
*** Bug 6141 has been marked as a duplicate of this bug. ***