Bug 6097 - INTERNAL ERROR: Signal 11 (similar to bug #5158?)
INTERNAL ERROR: Signal 11 (similar to bug #5158?)
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.5
x64 Windows XP
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 16:15 UTC by Pavel
Modified: 2009-03-27 06:27 UTC (History)
1 user (show)

See Also:


Attachments
samba log file (33.80 KB, text/plain)
2009-02-09 16:42 UTC, Pavel
no flags Details
log level 10 plus tcpdump between PC and PDC (437.68 KB, application/octet-stream)
2009-03-24 03:50 UTC, Pavel
no flags Details
patch (1.43 KB, patch)
2009-03-24 05:15 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel 2009-02-09 16:15:14 UTC
Hi,

i found following internal error in log file. It looks similar to bug #5158, but there are some differences in the trace and i'm unable to judge if those are the same traces.

I use samba as simple PDC (no printers) from Debian Lenny (v3.2.5-4).

[2009/02/09 11:44:49,  0] lib/fault.c:fault_report(40)
  ===============================================================
[2009/02/09 11:44:49,  0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 19933 (3.2.5)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2009/02/09 11:44:49,  0] lib/fault.c:fault_report(43)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2009/02/09 11:44:49,  0] lib/fault.c:fault_report(44)
  ===============================================================
[2009/02/09 11:44:49,  0] lib/util.c:smb_panic(1663)
  PANIC (pid 19933): internal error
[2009/02/09 11:44:49,  0] lib/util.c:log_stack_trace(1767)
  BACKTRACE: 18 stack frames:
   #0 /usr/sbin/smbd(log_stack_trace+0x1c) [0x5ae38d]
   #1 /usr/sbin/smbd(smb_panic+0x5b) [0x5ae49b]
   #2 /usr/sbin/smbd [0x59afb4]
   #3 /lib/libpthread.so.0 [0x7fea92b3fa80]
   #4 /usr/sbin/smbd(_lsa_LookupSids+0x194) [0x7e26da]
   #5 /usr/sbin/smbd [0x4e15ec]
   #6 /usr/sbin/smbd(api_rpcTNP+0x26d) [0x545065]
   #7 /usr/sbin/smbd(api_pipe_request+0x1f5) [0x54558d]
   #8 /usr/sbin/smbd [0x53f444]
   #9 /usr/sbin/smbd(write_to_pipe+0x115) [0x53dbbe]
   #10 /usr/sbin/smbd [0x775ac7]
   #11 /usr/sbin/smbd [0x776175]
   #12 /usr/sbin/smbd(reply_trans+0x727) [0x776e0f]
   #13 /usr/sbin/smbd [0x4a26ee]
   #14 /usr/sbin/smbd(smbd_process+0x417) [0x4a4198]
   #15 /usr/sbin/smbd(main+0x1ff6) [0x47182b]
   #16 /lib/libc.so.6(__libc_start_main+0xe6) [0x7fea910e21a6]
   #17 /usr/sbin/smbd [0x46ee09]
[2009/02/09 11:44:49,  0] lib/util.c:smb_panic(1668)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 19933]
Comment 1 Pavel 2009-02-09 16:42:43 UTC
Created attachment 3928 [details]
samba log file
Comment 2 Pavel 2009-03-23 03:21:09 UTC
Striked again...

[2009/03/23 08:41:08,  3] smbd/ipc.c:handle_trans(436)
  trans <\PIPE\> data=88 params=0 setup=2
[2009/03/23 08:41:08,  3] smbd/ipc.c:named_pipe(387)
  named pipe command on <> name
[2009/03/23 08:41:08,  4] rpc_server/srv_pipe_hnd.c:get_rpc_pipe(1258)
  search for pipe pnum=7061
[2009/03/23 08:41:08,  3] smbd/ipc.c:api_fd_reply(345)
  Got API command 0x26 on pipe "lsarpc" (pnum 7061)
[2009/03/23 08:41:08,  3] rpc_server/srv_pipe_hnd.c:free_pipe_context(519)
  free_pipe_context: destroying talloc pool of size 0
[2009/03/23 08:41:08,  4] rpc_server/srv_pipe.c:api_rpcTNP(2297)
  api_rpcTNP: lsarpc op 0xf - api_rpcTNP: rpc command: LSA_LOOKUPSIDS
[2009/03/23 08:41:08,  4] rpc_server/srv_lsa_hnd.c:find_policy_by_hnd_internal(168)
  Found policy hnd[0] [000] 00 00 00 00 02 00 00 00  00 00 00 00 C7 49 14 3D  ........ .....I.=
  [010] 4A 45 00 00                                       JE..
[2009/03/23 08:41:08,  0] lib/fault.c:fault_report(40)
  ===============================================================
[2009/03/23 08:41:08,  0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 17738 (3.2.5)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2009/03/23 08:41:08,  0] lib/fault.c:fault_report(43)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2009/03/23 08:41:08,  0] lib/fault.c:fault_report(44)
  ===============================================================
[2009/03/23 08:41:08,  0] lib/util.c:smb_panic(1663)
  PANIC (pid 17738): internal error
[2009/03/23 08:41:08,  0] lib/util.c:log_stack_trace(1767)
  BACKTRACE: 18 stack frames:
   #0 /usr/sbin/smbd(log_stack_trace+0x1c) [0x5ae38d]
   #1 /usr/sbin/smbd(smb_panic+0x5b) [0x5ae49b]
   #2 /usr/sbin/smbd [0x59afb4]
   #3 /lib/libpthread.so.0 [0x7f977aa92a80]
   #4 /usr/sbin/smbd(_lsa_LookupSids+0x194) [0x7e26da]
   #5 /usr/sbin/smbd [0x4e15ec]
   #6 /usr/sbin/smbd(api_rpcTNP+0x26d) [0x545065]
   #7 /usr/sbin/smbd(api_pipe_request+0x1f5) [0x54558d]
   #8 /usr/sbin/smbd [0x53f444]
   #9 /usr/sbin/smbd(write_to_pipe+0x115) [0x53dbbe]
   #10 /usr/sbin/smbd [0x775ac7]
   #11 /usr/sbin/smbd [0x776175]
   #12 /usr/sbin/smbd(reply_trans+0x727) [0x776e0f]
   #13 /usr/sbin/smbd [0x4a26ee]
   #14 /usr/sbin/smbd(smbd_process+0x417) [0x4a4198]
   #15 /usr/sbin/smbd(main+0x1ff6) [0x47182b]
   #16 /lib/libc.so.6(__libc_start_main+0xe6) [0x7f97790351a6]
   #17 /usr/sbin/smbd [0x46ee09]
[2009/03/23 08:41:08,  0] lib/util.c:smb_panic(1668)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 17738]
[2009/03/23 08:41:09,  0] lib/util.c:smb_panic(1676)
  smb_panic(): action returned status 0
Comment 3 Volker Lendecke 2009-03-23 04:19:47 UTC
I've looked at the code, but I'm afraid I have no clue where this might come from. Without a debug level 10 log or a way to reproduce it I don't know how to fix this.

Sorry,

Volker
Comment 4 Pavel 2009-03-24 03:50:06 UTC
Created attachment 4008 [details]
log level 10 plus tcpdump between PC and PDC
Comment 5 Pavel 2009-03-24 03:53:28 UTC
(In reply to comment #3)
> Without a debug level 10 log or a way to reproduce...

Hi,

it looks like, it happens whenever WinXP machine is first turnup in the morning and user tries to login into the domain. I hope that attached loglevel 10 and ip tracedump between PC and PDC in "Comment #4" can help somehow.
Comment 6 Volker Lendecke 2009-03-24 04:26:46 UTC
Thanks, got it reproduced here. Expect a fix soon.

Volker
Comment 7 Volker Lendecke 2009-03-24 05:15:09 UTC
Created attachment 4009 [details]
patch

Can you try the attached patch?

Thanks,

Volker
Comment 8 Volker Lendecke 2009-03-24 06:02:03 UTC
I've pushed the patch to all branches, it will be in the next releases.

Closing this bug, please re-open if it the patch does not work for you.

Thanks,

Volker
Comment 9 Pavel 2009-03-27 06:27:05 UTC
(In reply to comment #7)
> Can you try the attached patch?

Two days of testing and i can say that this problem no longer exists. Volker, it was incredibly fast replay and fix. Thank you. Also i'm going to ask Debian to apply this patch into stable.

I have at least another problem, which does not occure on all computer (#6097 was also caused by minority of all PC). So during the weekend i would report another bug.

Thanks Volker for amazing speed!
Pavel