Bug 5907 - ld.so.1: net: fatal: libtalloc.so: open failed: No such file or directory
ld.so.1: net: fatal: libtalloc.so: open failed: No such file or directory
Status: RESOLVED DUPLICATE of bug 5881
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.4
Sparc Solaris
: P3 minor
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 15:25 UTC by Wayne Rasmussen
Modified: 2013-02-18 13:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wayne Rasmussen 2008-11-17 15:25:25 UTC
net ads join get the error: 
ld.so.1: net: fatal: libtalloc.so: open failed: No such file or directory
Killed
warning: net ads join failed

top of config.log:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Samba configure 3, which was
generated by GNU Autoconf 2.61.  Invocation command line was

  $ ./configure --with-ldap --with-ads --with-pam --with-winbind --with-krb5=/us
r/local

## --------- ##
## Platform. ##
## --------- ##

hostname = newsystem
uname -m = sun4u
uname -r = 5.9
uname -s = SunOS
uname -v = Generic_118558-25

/usr/bin/uname -p = sparc
/bin/uname -X     = System = SunOS
Node = newsystem
Release = 5.9
KernelID = Generic_118558-25
Machine = sun4u
BusType = <unknown>
Serial = <unknown>
Users = <unknown>
OEM# = 0
Origin# = 1
NumCPU = 1

/bin/arch              = sun4
/usr/bin/arch -k       = sun4u
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/bin
PATH: /usr/local/sbin
PATH: /usr/ccs/bin
PATH: /bin
PATH: /usr/bin
PATH: /usr/ucb
PATH: /etc
PATH: /usr/etc
PATH: /usr/lib/uucp
PATH: /usr/sbin
PATH: /usr/sfw/bin
PATH: /u/mcs/bin
PATH: /u/mcs/utils
PATH: /usr/local/samba/bin
PATH: /usr/local/samba/sbin
PATH: /usr/wp80/wpbin
PATH: /usr/wp80/shbin10
PATH: /usr/opt/SUNWesm/sbin

************Work Around*********************
cd /usr/local/samba/lib
ln -s libtalloc.so.1 libtalloc.so
ln -s libtdb.so.1 libtdb.so
ln -s libwbclient.so.0 libwbclient.so

#might as well do these as well.
ln -s libnetapi.so.0 libnetapi.so
ln -s libsmbclient.so.0 libsmbclient.so
ln -s libsmbsharemodes.so.0 libsmbsharemodes.so


NOTE: to fix:
net ads join get the error: 
ld.so.1: net: fatal: libtalloc.so: open failed: No such file or directory
Killed
warning: net ads join failed

run: ln -s libtalloc.so.1 libtalloc.so

NOTE: to fix:
ld.so.1: net: fatal: libtdb.so: open failed: No such file or directory
Killed
warning: net ads join failed

run: ln -s libtdb.so.1 libtdb.so


NOTE: to fix:
ld.so.1: net: fatal: libwbclient.so: open failed: No such file or directory
Killed
warning: net ads join failed

run: ln -s libwbclient.so.0 libwbclient.so
Comment 1 Karolin Seeger 2009-08-06 09:37:52 UTC

*** This bug has been marked as a duplicate of bug 5881 ***