Bug 5882 - lost of all credential manager data on clients when forcing user password changing
lost of all credential manager data on clients when forcing user password cha...
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
x86 Windows XP
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-11-07 11:54 UTC by jmeuh
Modified: 2008-11-17 01:18 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description jmeuh 2008-11-07 11:54:41 UTC

I got a problem on WinXP clients when the user passwords are changed when they expires (i configured a policy of password expiration using smbldap-usermod to modify "sambaPwdMustChange" users ldap parameter and "pdbedit" to set "maximum password age" policy).
Indeed, when the change of the password is required on the client for any user, the change is made and all seems good. But when the client computer restarts, the user logs on whith the new password and then all data stored by the windows credential manager are lost. 
The credential manager helps the user to keep all identification data to all network ressources (excluding the samba domain ones) in the one of the application data subfolder of the user profile to avoid him to re-identify each time he access those ressources.
It's strange but it seems that those data are lost and i don't know why.
I tested the same opérations with a W2003 server and this problem does not appear.

Thanx for the help