Bug 5831 - cifs.upcall binary not cleaned out in 3.3.0's clean target?
cifs.upcall binary not cleaned out in 3.3.0's clean target?
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: Build environment
unspecified
Other Linux
: P3 minor
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 01:45 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2009-06-06 08:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2008-10-18 01:45:18 UTC
I found that problem while trying to compile samba twice in the same
directory while fight^W preparing Debian packages.

Apparently bin/cifs.upcall is not cleaned out by the clean target
while it was in 3.2.* series.

My wild guess is that this pertains to source/Makefile.in:

In 3.2.4:

SBIN_PROGS = bin/smbd@EXEEXT@ bin/nmbd@EXEEXT@ @SWAT_SBIN_TARGETS@ @EXTRA_SBIN_PROGS@ @CIFSUPCALL_PROGS@

ROOT_SBIN_PROGS = @CIFSMOUNT_PROGS@

In 3.3.0-pre2:

SBIN_PROGS = bin/smbd@EXEEXT@ bin/nmbd@EXEEXT@ @SWAT_SBIN_TARGETS@ @EXTRA_SBIN_PROGS@
Comment 1 Karolin Seeger 2009-06-06 08:51:15 UTC
Cannot reproduce in the current v3-3-test branch, so it seems to be fixed meanwhile.
Closing out bug report.

Please re-open if it's still an issue.
Thanks for reporting!