Bug 5643 - unexpected.tdb grows unchecked
unexpected.tdb grows unchecked
Status: RESOLVED DUPLICATE of bug 5684
Product: Samba 3.2
Classification: Unclassified
Component: Config Files
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-07-29 10:17 UTC by Mark D. McBride
Modified: 2008-08-17 03:38 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Mark D. McBride 2008-07-29 10:17:49 UTC
The database file unexpected.tdb grows until filesystem is full.

Samba 3.2.0 on AIX 5.3 using binaries from pware.

After sopping Samba and rm the unexpected.tdb file to gain space. I listed the file and then did a tdbtool info on it and the numbers did not match. The unexpected.tdb file continues to grow even when the info numbers reduce.
>ls -l unexpected.tdb
-rw-r--r--    1 root     system      1728512 Jul 29 11:10 unexpected.tdb
>tdbtool unexpected.tdb info
28 records totalling 5796 bytes
Comment 1 Volker Lendecke 2008-07-29 10:26:06 UTC
On a busy network, I would not call 1728512 bytes particularly large. The fact that tdbtool info reports less bytes than the file size is expected, tdb does not really shrink its database files. How large does the file get for you?

Comment 2 Mark D. McBride 2008-07-29 11:47:36 UTC
On another system in the test network with very little traffic and 1 client.

-rw-r--r--    1 root     system    150401024 Jul 29 11:24 unexpected.tdb

Comment 3 Mark D. McBride 2008-07-29 11:51:39 UTC
Also on my busy system on 3.0.28 it is:

-rw-r--r--   1 root     system       200704 Jul 24 13:08 unexpected.tdb

Comment 4 Volker Lendecke 2008-07-29 14:50:39 UTC
hmmmm.... If you bzip2 -9 the huge one, does it shrink enough that you can send it to me?

Comment 5 Mark D. McBride 2008-07-30 07:37:05 UTC
I got it down to:

-rw-r--r--    1 root     system      8788015 Jul 30 08:15 unexpected.tdb.bz2

But that was still too big for bugzilla. Is there another location or method to submit the file?
Comment 6 Volker Lendecke 2008-07-30 07:41:04 UTC
Please send it to me directly per mail.


Comment 7 Mark D. McBride 2008-07-30 08:03:41 UTC
It seems that your mailbox will not accept it. Tried 2 times from 2 different email systems.

Do you have an FTP site?
Comment 8 Volker Lendecke 2008-07-30 08:13:28 UTC
Sorry, no. From other senders I frequently receive huge mails, so at sometimes it works for my mailbox.

Comment 9 Volker Lendecke 2008-07-30 10:20:20 UTC
There are VERY many dead records in your tdb. Is it possible that a process that accesses the tdb hangs for extended periods of time? This is the only explanation for this excessive number of dead records.

If you happen to have lsof installed, you might be able to find all processes accessing that file.

Comment 10 Mark D. McBride 2008-07-30 10:34:38 UTC
Hmmmm... lsof "Segmentation fault(coredump)" when Samba is active.

This is a prebuilt lsof, so I will download the source and compile it.
Comment 11 Mark D. McBride 2008-07-30 11:02:34 UTC
Build new lsof. Just one process accessing file:

nmbd      21874    root   14ur VREG      10,11     356352 258091 /opt (/dev/hd10opt)

New file. starting to grow.

I also checked it on another system:

nmbd      25464   root   13ur VREG      10,11   16146432  40987 /opt/pware (/dev/pwarelv)
Comment 12 Volker Lendecke 2008-08-17 03:38:06 UTC

*** This bug has been marked as a duplicate of 5684 ***