Bug 5608 - creating symlink for libtalloc.so.1 fails on Solaris 8
creating symlink for libtalloc.so.1 fails on Solaris 8
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.0
Other Solaris
: P3 normal
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-10 15:31 UTC by Michael Adam
Modified: 2008-08-18 09:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Adam 2008-07-10 15:31:31 UTC
This has been reported on the samba mailing list by Oliver Weinmann and William Edward Wilson.

...
Linking shared library in/libtalloc.so
ln: cannot create bin/libtalloc.so.1: File exists
*** Error code 2
make: Fatal error: Command failed for target `bin/libtalloc.so'
...

The problem is that ln -s -f fails on Solaris when the link already exists.
The issue is (should be) fixed in v3-3-test. But since this is part of a bigger rewrite of the library build system, I am filing a separate bug for 3.2.0.

Michael
Comment 1 Karolin Seeger 2008-08-18 09:15:30 UTC
Will be in 3.2.2.
Closing out bug report.