Bug 5550 - libsmbclient doesn't have a smbc_chown anymore
libsmbclient doesn't have a smbc_chown anymore
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: libsmbclient
3.2.0
Other Linux
: P3 regression
: ---
Assigned To: Derrell Lipman
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-18 09:28 UTC by Andreas Schneider
Modified: 2008-06-18 10:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2008-06-18 09:28:28 UTC
What happened with smbc_chown in Samba 3.2? It has a prototype in libsmbclient.h but there is no function.

It looks like it as been accidentally removed during the refactoring?

samba/git/source(v3-2-test)> grepr smbc_chown *
include/libsmbclient.h:1606:int smbc_chown(const char *url, uid_t owner, gid_t group);
Comment 1 Derrell Lipman 2008-06-18 10:01:56 UTC
I don't believe that function has ever been implemented.  I've removed the prototype.

You should be able to change the ownership of a file using smbc_setxattr().

Cheers,

Derrell