Bug 5456 - ^C in smbpasswd leaves the terminal in a non-echo state.
^C in smbpasswd leaves the terminal in a non-echo state.
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Client tools
3.2.0
Other Linux
: P3 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-09 16:53 UTC by Jeremy Allison
Modified: 2008-05-20 02:47 UTC (History)
0 users

See Also:


Attachments
Patch (686 bytes, patch)
2008-05-09 16:53 UTC, Jeremy Allison
no flags Details
patch (972 bytes, patch)
2008-05-13 07:10 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2008-05-09 16:53:33 UTC
rep_getpass will leave the terminal in a non-echoing state if the command is cancelled with a ^C at the prompt.
Jeremy.
Comment 1 Jeremy Allison 2008-05-09 16:53:59 UTC
Created attachment 3286 [details]
Patch

Patch for 3.2.
Jeremy.
Comment 2 Volker Lendecke 2008-05-13 05:23:09 UTC
Confirmed. Fixed. Thanks :-)
Comment 3 Volker Lendecke 2008-05-13 06:32:01 UTC
Hmmm. I only tested smbpasswd.... smbclient for me still shows this. Seems to be my bug according to your fix.

Working on it :-)
Comment 4 Volker Lendecke 2008-05-13 07:10:21 UTC
Created attachment 3287 [details]
patch

This one fixes the problem for me in smbclient -- please test :-)
Comment 5 Volker Lendecke 2008-05-20 02:47:45 UTC
Apparently I had tested on old code. Sorry for the noise.

Volker