Bug 5308 - fail "make test_nss_modules" on samba 3.2.0pre2
fail "make test_nss_modules" on samba 3.2.0pre2
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.0
x86 Linux
: P3 minor
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 23:35 UTC by Yasuma Takeda
Modified: 2008-03-07 03:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuma Takeda 2008-03-05 23:35:15 UTC
"make test_nss_modules" fails on samba 3.2.0pre2.

$ make test_nss_modules
Testing nsswitch/libnss_winbind.so nsswitch/libnss_wins.so 
dlopen() of "./nsswitch/libnss_winbind.so" succeeded.
dlopen() of "./nsswitch/libnss_wins.so" failed: libtalloc.so.1: cannot open shared object file: No such file or directory
make: *** [test_nss_modules] error

Because libnss_wins.so is linked to libtalloc.so and libtdb.so which are included in source/bin.
Comment 1 Ricardo Santos 2008-03-06 01:01:21 UTC
(In reply to comment #0)
> dlopen() of "./nsswitch/libnss_wins.so" failed: libtalloc.so.1: cannot open
> shared object file: No such file or directory

After "make install" is missed the symbol link to lib:

/usr/lib
-rwxr-xr-x 1 root root 88161 2008-03-06 02:57 libtalloc.so
lrwxrwxrwx 1 root root    12 2008-03-04 19:37 libtalloc.so.1 -> libtalloc.so

Seems that libtdb.so has the same problem.
Comment 2 Michael Adam 2008-03-06 01:20:07 UTC
In order to run "make test" and friends, 
you need to set LD_LIBRARY_PATH=./bin (e.g.). 
Comment 3 Michael Adam 2008-03-06 03:29:29 UTC
Ricardo: The problem, you describe is a different issue.
The make test calls are performed from inside the source dir.

Cheers - Michael
Comment 4 Michael Adam 2008-03-06 03:31:27 UTC
Yasuma:

I have fixed this issue in v3-2-test by correctly setting LD_LIBRARY_PATH
for the test_shlibs, test_nss_modules and test_pam_modules targets in
21a527569bccff8e8cb6e751c9f3fce6ff598204.

Cheers - Michael
Comment 5 Yasuma Takeda 2008-03-07 03:30:59 UTC
I confirmed this bug fixed. Thanks!