Bug 516 - wbinfo -t fails on Samba 3.0.0 stable
wbinfo -t fails on Samba 3.0.0 stable
Product: Samba 3.0
Classification: Unclassified
Component: winbind
All Linux
: P3 minor
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2003-09-26 07:35 UTC by Ken Hall
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Ken Hall 2003-09-26 07:35:19 UTC
I upgraded a couple of systems to Samba 3.0.0 stable from rc4, and ran into the 
following.  Before the upgrade, I was able to check the secret as follows:

kehall@lnxsmb3t:/var/log> wbinfo -t
checking the trust secret via RPC calls succeeded

But after, I get this:

lnxsmb3t:/etc/logrotate.d # wbinfo -t
checking the trust secret via RPC calls failed
error code was  (0x0)
Could not check secret

Winbindd also complains about the "realm" parm in smb.conf, but it appears it's 
done this all along.
Comment 1 Gerald (Jerry) Carter 2003-09-26 07:39:19 UTC
Are you sure you are running the correct version of winbindd?
What is the error message about the realm?  Also, did you
install the new libnss_winbindd.so library with 3.0.0?
Comment 2 Ken Hall 2003-09-26 07:53:32 UTC
lnxsmb3t:~ # wbinfo -V
Version 3.0.0
lnxsmb3t:/var/log # which wbinfo
lnxsmb3t:~ # winbindd -V
Version 3.0.0
lnxsmb3t:~ # rpm -qf /usr/bin/wbinfo
(ps -l confirms winbindd loaded from /usr/sbin)
lnxsmb3t:~ # rpm -qf /usr/sbin/winbindd 
lnxsmb3t:~ # rpm -qf /lib/libnss_winbind.so 

This appeared after I upgraded from RC4 to stable.  I noticed it after 
rejoining the domain on another system that was upgraded from 2.2.8a to 
3.0.0stable, so I tested it on this one, which has never had a previous release 

I built the RPM myself using the same spec file I've used for the 3.0 beta and 
rc versions.

On the winbindd/realm issue:

[2003/09/26 10:47:30, 1] nsswitch/winbindd.c:main(832)
  winbindd version 3.0.0 started.
  Copyright The Samba Team 2000-2003
[2003/09/26 10:47:30, 0] param/loadparm.c:map_parameter(2422)
  Unknown parameter encountered: "realm"
[2003/09/26 10:47:30, 0] param/loadparm.c:lp_do_parameter(3150)
  Ignoring unknown parameter "realm"

I checked back in the log, and RC4 did the same thing I don't know about 
previous versions.  I've run a couple of the betas, and RC1, 3, and 4.
Comment 3 Ken Hall 2003-09-26 07:56:32 UTC
I just tried it again, and now it works.  Maybe there was a delay while the 
domain join propagated, and I was picking up a server that wasn't current.

Still getting the message about "realm" though.
Comment 4 Gerald (Jerry) Carter 2003-09-26 08:45:19 UTC
If winbindd complains that "realm" is an unknown parameter, then 
ADS support was not compiled in.  The delay period before
wbinfo -t suceeds sounds like a name resolution issue where 
winbindd is busying trying to contact trusted domains.

How did you join the domain?  What type of domain is it (NT4 or AD)?
Comment 5 Ken Hall 2003-09-26 09:00:42 UTC
It's a Win2k AD. 

I don't have "--with-ads" in the configure.  configure --help says it defaults 
to "auto".  What's required to enable it, other than adding the parm to 
Comment 6 Ken Hall 2003-09-26 10:10:25 UTC
I went back over my build, and it looks like I lost AD detection when I removed 
MIT Kerberos and replaced heimdal.  The configure option was still pointing to 
the MIT directory.  It's building now with "--with-ads" forced on.  If this 
goes successfully, I'll mark this resolved.  I also got some email help from 
Steve French.  Thanks for the help.
Comment 7 Ken Hall 2003-09-26 12:20:32 UTC
Product built successfully, and no more errors are displayed.  Thanks again.
Comment 8 Gerald (Jerry) Carter 2003-09-26 13:06:35 UTC
local configuration issue.  Closing out.
Comment 9 Gerald (Jerry) Carter 2005-11-14 09:29:45 UTC
database cleanup