Bug 5131 - Feature request: DFS support
Feature request: DFS support
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: File services
unspecified
All All
: P3 enhancement
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks: 6714
  Show dependency treegraph
 
Reported: 2007-12-08 14:09 UTC by Matthias Dieter Wallnöfer
Modified: 2010-05-21 03:24 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-12-08 14:09:21 UTC
Sooner or later we should be able to export the SYSVOL share as DFS.
Comment 1 Matthieu Patou 2009-06-13 15:29:24 UTC
Can we have an update on this subject ? as s4 is moving toward being more and more able to run on more that one server (via openldap replication for instance) then it's normal that sysvol should be accessible from both server as well via the ad'hoc protocol.
Comment 2 Matthieu Patou 2009-09-12 05:05:47 UTC
Mathias,
I think that in fact it's two different things to my mind even if they are tightly linked.

One part is able to present SYSVOL as DFS share, another is to have the content of the share to be replicated.

The first part is clearly our target and the sooner the better (well after reading doc from microsoft it seems not such big stuff ...) as our clients (XP, Vista) will need it (check mails at:http://lists.samba.org/archive/samba-technical/2009-August/066366.html).
There is also Constantine Vetoshev (check http://lists.samba.org/archive/samba-technical/2009-September/066524.html) that is working on something.

FRS is usefull in a mixed Windows/Samba Domain I don't have any idea of wether this is our priority or not ... And if it is I would recommend to focus on DFS replication which is the new tech used by Microsoft to replicate shares as they are phasing out FRS (DFS is available in w2k8).
Comment 3 Matthias Dieter Wallnöfer 2010-03-04 03:51:26 UTC
*** Bug 6714 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Dieter Wallnöfer 2010-03-04 04:28:07 UTC
Mark this again only for "DFS support".
Comment 5 Matthias Dieter Wallnöfer 2010-03-08 04:33:21 UTC
Reassign file server related bugs up to tridge.
Comment 6 Matthieu Patou 2010-05-14 17:09:37 UTC
This is under process there is already patches for this that are reviewed for the moment.
Comment 7 Mohammad Nazeem Durgahee 2010-05-20 17:11:03 UTC
What about DFSR is that under review as well
Comment 8 Matthieu Patou 2010-05-21 03:01:43 UTC
Matthias this bug should be fixed in fc94c50a9fe0ef344068feafa21d85adb149b6b3.
At least at the level of what we want to have for a beta.
Comment 9 Matthieu Patou 2010-05-21 03:03:47 UTC
(In reply to comment #7)
> What about DFSR is that under review as well
> 

This is the purpose of the bug 6714.
As I said on lists, DFSR will most probably be implemented but it's a big beast it will takes me a couple of time to get it. I have for the moment no idea of when I'll start it and how long it will takes. But if you want to start a implementation please feel free.
Comment 10 Matthias Dieter Wallnöfer 2010-05-21 03:24:18 UTC
Okay, marking as FIXED (through to suggestion by ekacnet).