Bug 4943 - Processes receives the rights of the superuser aftetr SIGHUP
Processes receives the rights of the superuser aftetr SIGHUP
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
x64 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-08-31 05:15 UTC by Alexander Korkov
Modified: 2007-08-31 14:09 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Korkov 2007-08-31 05:15:16 UTC
Child process, which has rights of normal users or "nobody user" receives root's privileges after few signals "SIGHUP" sent to the parent smbd process. 
Child process, which start when anybody connect to the smb-services, and which are visible in the table of command "smbstatus".
Comment 1 Gerald (Jerry) Carter 2007-08-31 07:22:50 UTC
Please provide more details.  It is completely normal for smbd to 
switch between running as root and running as the connected user.
Comment 2 Alexander Korkov 2007-08-31 09:27:55 UTC
Ok, I have main process, which running from root and which have superuser rights.
When guest user connected, smbd run child process, which have nobody privileges.
It's normal.
For example, I connect to the my incoming throw Konqueror.
smbstatus shown, that child process have pid = 5567.
ps axu | grep 5567   shown, that process running from user "nobody"
Few times I run command
ps axu | grep 5567 

and see, that process 5567  running by "nobody"
I run "ps axu | grep 5567" many times, and after some time I can see that the process have root uid.
Or, when process dying, it gets root privileges?
It's normal?
Comment 3 Gerald (Jerry) Carter 2007-08-31 09:54:22 UTC
This is normal.  No bug here.
Comment 4 Alexander Korkov 2007-08-31 13:39:04 UTC
Ok, then I have question.
I discovered this when I wrote my VFS module.
I need use root privileges when guests connect to the my 
services,  but smbd runs process from user nobody...
How I can get root privileges in my VFS module?
Even on a short time interval.
Or give me answer , where can I ask my question?
Comment 5 Gerald (Jerry) Carter 2007-08-31 13:40:39 UTC
Please post your question to the samba-technical mailing list.