Bug 4650 - oplock issue!
oplock issue!
Status: RESOLVED DUPLICATE of bug 4651
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x86 Windows XP
: P3 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 08:24 UTC by ylet
Modified: 2007-07-20 16:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ylet 2007-05-23 08:24:11 UTC
i am using three computer, named A,B,C , A and B all are linux and C is windowsXP
A is a samba(3.0.25) server ip 10.10.1.39 and B(kernel 2.6.21) 

B do the operations sequence 
B: mount -t cifs //10.10.1.39/sdb /mnt/sdb
B:service smb start (share name is sdb)
and B use samba(3.0.25) and have two NIC (10.10.1.151 and 10.10.2.151)

C mapped B's shared volume 
//10.10.1.151/sdb   to  Z:\
//10.10.2.151/sdb   to  Y:\

now, i begin to read the same file named x.dat from Z and Y

 added speed come from these two process is very slow!

i traced the oplock and i can see the client(B) first get the pSMB of OplockLevel=1 , and get the pSMB of OplockLevel=0 after seconds.   

this means when two and more process read the same file in above box, B can not cache files! why?
Comment 1 Steve French 2007-07-20 16:10:02 UTC

*** This bug has been marked as a duplicate of 4651 ***