Bug 4461 - smbd crashes in _lsa_lookup_sids during login
smbd crashes in _lsa_lookup_sids during login
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.23c
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 01:51 UTC by Paul Arnold
Modified: 2007-03-27 20:27 UTC (History)
0 users

See Also:


Attachments
Relevent parts of the smd logfile (including stack trace) (20.89 KB, text/plain)
2007-03-23 02:07 UTC, Paul Arnold
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Arnold 2007-03-23 01:51:13 UTC
Smbd crashes 9 times (exactly and every time) when a particular user attempts to login. The login succeeds. No core is dumped despite panic-action saying otherwise.
Comment 1 Paul Arnold 2007-03-23 02:07:06 UTC
Created attachment 2345 [details]
Relevent parts of the smd logfile (including stack trace)
Comment 2 Volker Lendecke 2007-03-23 02:27:20 UTC
What exact Unix and what package are you using?

Would it be possible that you run smbd under valgrind and send in the corresponding logfiles after running smbd with debug symbols.

You might want to look at the history of bug 4434 how fast the bug was fixed after  the reporter sent in this information ;-)

Volker
Comment 3 Paul Arnold 2007-03-27 20:27:42 UTC
Running Debian 3.1 stable with the samba packages from backports.org. 
samba-3.0.23c-1~bpo
samba-common-3.0.23c-1~bpo

I'll try and build a debug version later today and run it under valgrind

thanks

Paul