Bug 4385 - hidden attribute disappears when copying directories
hidden attribute disappears when copying directories
Status: RESOLVED DUPLICATE of bug 4978
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.23d
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 09:17 UTC by James Dinkel
Modified: 2007-11-12 12:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Dinkel 2007-02-09 09:17:39 UTC
This is from a Windows XP SP2 (fully updated) client connecting to Samba with AD authentication on a Debian Etch server (fully updated, just yesterday) using ACLs and Extended Attributes enabled on the Ext3 file system and within Samba.

Steps to reproduce:
1. Set Windows to view hidden files and folders.

2. Create a folder on your Windows desktop

3. Open the folder properties and set the folder to 'hidden'

4. Copy the folder up to your Samba file share

5. Observer that the folder is no longer hidden

I tried this on a Windows file share, and the folder does remain hidden.  Also this does not affect files - hidden files remain hidden when copied.
Comment 1 rvjcallanan 2007-09-07 14:39:11 UTC
Is it possible to expedite this bug-fix?
It has serious repercusions for roaming profiles!
Comment 2 Gerald (Jerry) Carter 2007-09-07 14:45:58 UTC
Check you log files.  And make sure that the fs is mounted with the 
"acl,user_xattr" options.  Other than that, there's not enough information
to go on here.  The functionality works fine for me.
Comment 3 rvjcallanan 2007-09-07 14:52:01 UTC
Note, this problem also affects folder archive and system flags when using EA.
It seems that the underlying samba copy primitives are not preserving EAs in the case of directories (but they do work okay for files). 

I am surprised that this bug has not been elevated. It is very fundamental to any installation using roaming profiles. 
Comment 4 rvjcallanan 2007-09-07 15:02:41 UTC
(In reply to comment #2)
> Check you log files.  And make sure that the fs is mounted with the 
> "acl,user_xattr" options.  Other than that, there's not enough information
> to go on here.  The functionality works fine for me.

My fs is mounted with user_xattr (but NOT acl). As I said, *file* copy operations preserve bits okay but *directory* operations do not. *However*, I can manually set directory attributes *after* copy operation. Therefore my fundamentals seem okay. So it seesm that the copy primitive is neglecting preservation of folder EAs but not file EAs.

BTW, I am on Ubuntu Server 6.06 LTS (Dapper) with Samba 3.0.22 containing back ports (latest offical package). Log files also seem fine.
Comment 5 rvjcallanan 2007-09-07 17:06:33 UTC
(In reply to comment #2)
> Check you log files.  And make sure that the fs is mounted with the 
> "acl,user_xattr" options.  Other than that, there's not enough information
> to go on here.  The functionality works fine for me.

If its working okay at your end, this problem may have been cured as a by-product of a later release. I am anxious to have a fix for this backported to Ubuntu 6.06 Server LTS/Samba 3.0.22. I have searched Samba Changelog but found nothing obvious. Any ideas?

Comment 6 rvjcallanan 2007-09-14 18:25:43 UTC
(In reply to comment #2)
> Check you log files.  And make sure that the fs is mounted with the 
> "acl,user_xattr" options.  Other than that, there's not enough information
> to go on here.  The functionality works fine for me.

Jerry, I have now reproduced problem on a new server running latest RedHat/CentOS 5.0 updates with Samba 3.0.23c-2.el5.2.0.2. I am unable to test with any later version of Samba on a stable distro.

Are you *quite sure* that you do *not* have this problem at your end? Please understand that the problem only happens when copying *folders* (not files), but I *can* set the *folder* attribute manually after the copy. BTW, this problem has also been reported on Samba Linux Group on Google. I believe Jeremy A advised to follow up with a bug report.

If you are still adamant that you do not have the problem, can you please state the version of Samba you are running so that we can definitely ascertain that a bug fix has happened somewhere along the line. I cannot see anything obvious from changelog.

If it turns out that this bug is current, is it possible to notch up the severity level. I emphasis that this is *fundamental* to faithfully emulating the behaviour of an MS server, particularly when using roaming profiles. File/folder attributes are just as important as *file data* for certain client applications including Windows itself.

If there is a shortage of manpower at the moment, perhaps you can point me to the relevant Samba source modules...I am more than willing to have a look through the code myself and see if I spot anything obvious.

Comment 7 James Dinkel 2007-09-18 09:49:04 UTC
True, it would be nice to know what version of Samba and the OS that Jerry used to test this.  And if he built from source or used the Samba package from a repo.  I have verified this affects Debian, Ubuntu Dapper, and CentOS 5 using only Stable versions of the OS and packages from the repositories.
Comment 8 rvjcallanan 2007-09-28 05:55:46 UTC
(In reply to comment #7)

I believe this is a duplicate of 4978 which has just been fixed by JRA.

Comment 9 Jeremy Allison 2007-11-12 12:50:36 UTC

*** This bug has been marked as a duplicate of 4978 ***