Bug 4059 - password change during logon broken with w2k w/o servicepack
password change during logon broken with w2k w/o servicepack
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.23b
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 07:49 UTC by Björn Jacke
Modified: 2006-09-02 16:47 UTC (History)
0 users

See Also:


Attachments
log (149.16 KB, application/x-gzip)
2006-08-27 07:51 UTC, Björn Jacke
no flags Details
sniff (13.37 KB, application/x-gzip)
2006-08-27 07:52 UTC, Björn Jacke
no flags Details
fix (1.36 KB, patch)
2006-09-02 16:47 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2006-08-27 07:49:18 UTC
When there are users with an expired password their w2k workstations refuse to change the password during logon. The client says that the domain is not available. This happens with w2k w/o service pack and with w2k SP2, too.
Interesting in the log is:
NTLMSSP NTLM1 packet check failed due to invalid signature!
Comment 1 Björn Jacke 2006-08-27 07:51:37 UTC
Created attachment 2108 [details]
log
Comment 2 Björn Jacke 2006-08-27 07:52:03 UTC
Created attachment 2109 [details]
sniff
Comment 3 Volker Lendecke 2006-08-30 02:50:49 UTC
Ok, got it reproduced with smbtorture from Samba4. I'll work on it.

Volker
Comment 4 Volker Lendecke 2006-09-02 16:47:17 UTC
Created attachment 2120 [details]
fix

The attached patch fixes it for me. Please re-open if it doesn't for you.
Comment 5 Volker Lendecke 2006-09-02 16:47:50 UTC
fixed with r18008