Bug 3979 - writefd_unbuffered failed to write 4092 bytes phase send_file_entry broken pipe
writefd_unbuffered failed to write 4092 bytes phase send_file_entry broken pipe
Status: RESOLVED WORKSFORME
Product: rsync
Classification: Unclassified
Component: core
2.6.8
Other Linux
: P3 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 01:36 UTC by C Des
Modified: 2006-10-15 11:29 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C Des 2006-07-30 01:36:27 UTC
I reopen this bug 1959 as the same problem occurs now on my server after month of clean operation...same message with v2.6.8 of rsync on both servers.
Rsync works fine on A->A and B->B but any sync from A->B hangs.
I tried all the solution of bug 1959 followup....nothing works.

Help appreciated.

Regards,

Chris

+++ This bug was initially created as a clone of Bug #1959 +++

we are doing rsync from server A -> B and A->C. 

A, C are running on Linux 2.4.9-e-34 and B is running on Linux 2.4.9-e-38

the following rsync command works just fine from A->B:

rsync --exclude-from /local/dba/scripts/shoprod1_exclude_applfiles.txt -rlvz -e
ssh /prod/applmgr/1159/ applprod@twnprod1:/prod/applmgr/1159/

the "same" command doesnt work from A->C:

the following rsync command works just fine from A->B:

rsync --exclude-from /local/dba/scripts/shoprod1_exclude_applfiles.txt -rlvz -e
ssh /prod/applmgr/1159/ applprod@twnprod2:/prod/applmgr/1159/

we get the followin error at different stages, e.g. build stage or after
processing a few files:

rsync: writefd_unbuffered failed to write 4092 bytes: phase "send_file_name":
broken Pipe
rsync error: error in rsync protocol data stream (code 12) at io.c(836)

we are using rsync2.6.2 protocol version 28.

Im at a loss to understand why this is happening.

I already tried -vv option -> same error comes after processing some files from
the exclusion file

If I use the -vvv option, it hangs on a particular command like this on server A:

[sender] make_file(per/11.5.0/help/US/puploadw.htm,*,2)
[sender] make_file(per/11.5.0/help/US/puplorgd.htm,*,2)
--> this is where it hangs..

doing a strace on the rsync process on server A shows :

select(5,NULL, [4], NULL, {16,970000}) = 0 (Timeout)
select(5,NULL, [4], NULL, {60, 0}) = 0 (Timeout)
select(5,NULL, [4], NULL, {60, 0}) = 0 (Timeout)
..

strace on rsync process on server C shows:

select(2,NULL, [1], NULL, {29,290000}) = 0 (Timeout)
select(2,NULL, [1], NULL, {60, 0}) = 0 (Timeout)
select(2,NULL, [1], NULL, {60, 0}) = 0 (Timeout)
..

and so it hangs.. without doing anything..
Comment 1 Wayne Davison 2006-09-17 18:39:03 UTC
Your bug report is contradictory: at one spot it says you're using 2.6.8, at another 2.6.2.  Please follow the procedures for debugging why the remote rsync is going away (see the Issues and Debuggin webpage) and cite any system-call tracing and netstat output for a hang (be sure to get both processes from the receiving side when pushing files).
Comment 2 Timothee Besset 2006-09-17 18:43:41 UTC
fwiw we fixed our similar case of report this by using a Linux rsync server instead of cygwin ( TTimo - removing myself from CC )
Comment 3 Wayne Davison 2006-10-15 11:29:21 UTC
Closing due to lack of response.  Feel free to add more information to this bug should the problem recur.